aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2019-09-04 18:11:25 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2019-09-04 18:11:25 +0200
commit99a5e285887c4a10aaf06d8e01fae0707995da00 (patch)
treed02894bce355551247d4cb45f7617f0c30d10369 /target/linux
parentda3f5b21960d230723a4aefd5a2a3cc709eda21b (diff)
downloadupstream-99a5e285887c4a10aaf06d8e01fae0707995da00.tar.gz
upstream-99a5e285887c4a10aaf06d8e01fae0707995da00.tar.bz2
upstream-99a5e285887c4a10aaf06d8e01fae0707995da00.zip
brcm2708: bcm2711: remove custom config file
Forcing arm_64bit is no longer required with latest firmware. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/brcm2708/image/Makefile4
-rw-r--r--target/linux/brcm2708/image/config-bcm2711-arm64.txt17
2 files changed, 1 insertions, 20 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 97f127d307..01d1bf585f 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -27,7 +27,7 @@ define Build/boot-common
mcopy -i $@.boot $(KDIR)/COPYING.linux ::
mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
mcopy -i $@.boot cmdline.txt ::
- mcopy -i $@.boot $(BOOT_CONFIG) ::config.txt
+ mcopy -i $@.boot config.txt ::
mcopy -i $@.boot distroconfig.txt ::
mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_IMG)
$(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
@@ -68,7 +68,6 @@ define Device/Default
IMAGES := factory.img.gz sysupgrade.img.gz
IMAGE/sysupgrade.img.gz := boot-common | boot-2708 | sdcard-img | gzip | append-metadata
IMAGE/factory.img.gz := boot-common | boot-2708 | sdcard-img | gzip
- BOOT_CONFIG := config.txt
endef
define Device/rpi
@@ -141,7 +140,6 @@ define Device/rpi-4
kmod-brcmfmac wpad-basic
IMAGE/sysupgrade.img.gz := boot-common | boot-2711 | sdcard-img | gzip | append-metadata
IMAGE/factory.img.gz := boot-common | boot-2711 | sdcard-img | gzip
- BOOT_CONFIG := config-bcm2711-arm64.txt
endef
ifeq ($(SUBTARGET),bcm2711)
TARGET_DEVICES += rpi-4
diff --git a/target/linux/brcm2708/image/config-bcm2711-arm64.txt b/target/linux/brcm2708/image/config-bcm2711-arm64.txt
deleted file mode 100644
index 984aab585e..0000000000
--- a/target/linux/brcm2708/image/config-bcm2711-arm64.txt
+++ /dev/null
@@ -1,17 +0,0 @@
-################################################################################
-# Bootloader configuration - config.txt
-################################################################################
-
-################################################################################
-# For overclocking and various other settings, see:
-# https://www.raspberrypi.org/documentation/configuration/config-txt/README.md
-################################################################################
-
-# Force aarch64
-arm_64bit=1
-
-# OpenWrt config
-include distroconfig.txt
-
-[all]
-# Place your custom settings here.