aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2018-02-15 23:15:53 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2018-02-22 18:53:22 +0100
commit8c64824576598117958691853de68bf4dcfc3c06 (patch)
tree5b89f50f6d9acd9f846def27271ce4b0e9651cb2 /target/linux
parent907d67491068890e27f7611da5c5c4d44a672c3c (diff)
downloadupstream-8c64824576598117958691853de68bf4dcfc3c06.tar.gz
upstream-8c64824576598117958691853de68bf4dcfc3c06.tar.bz2
upstream-8c64824576598117958691853de68bf4dcfc3c06.zip
ar71xx: add support for GainStrong Oolite V5.2
GainStrong Oolite V5.2 is a small (39.5 x 78 mm), dual-band system on module, based on Qualcomm QCA9531 + QCA9887. All QCA9531 SOC GPIOs are available on castellated pins. Specification: - 650/400/200 MHz (CPU/DDR/AHB) - 64/128 MB of RAM (DDR2) - 16 MB of FLASH (SPI NOR) - 5x 10/100 Mbps Ethernet (all ports available on castellated pins) - 2T2R 2.4 GHz (QCA9531), with ext. PA and LNA - 1T1R 5 GHz (QCA9887) with ext. FEM (SKY85710-11) - 3x U.FL - 1x USB 2.0 The dedicated development board includes 5 FE ports, USB 2.0 port, two buttons (one directly connected to SOC reset input), header with all GPIOs and several LEDs. Flash instruction: Vendor firmware is based on OpenWrt. LuCI or sysupgrade can be used to flash OpenWrt firmware. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network2
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh1
-rw-r--r--target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata2
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh6
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh2
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/config-4.91
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt11
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-gs-oolite-v5-2.c111
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h2
-rw-r--r--target/linux/ar71xx/generic/config-default1
-rw-r--r--target/linux/ar71xx/image/generic.mk19
13 files changed, 160 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index 42b40e35ff..8f492cbf02 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -29,6 +29,8 @@ ar71xx_setup_interfaces()
minibox-v1|\
mynet-n600|\
oolite-v1|\
+ oolite-v5.2|\
+ oolite-v5.2-dev|\
qihoo-c301|\
r602n|\
rb-750|\
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 38df0c15d1..6b53ad03c7 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -205,6 +205,7 @@ get_status_led() {
status_led="$board:blue:status"
;;
e600g-v2|\
+ oolite-v5.2-dev|\
wifi-pineapple-nano)
status_led="$board:blue:system"
;;
diff --git a/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index e6ea873e40..c93ce2a614 100644
--- a/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -75,6 +75,8 @@ case "$FIRMWARE" in
dlan-pro-1200-ac|\
e1700ac-v2|\
e600gac-v2|\
+ oolite-v5.2|\
+ oolite-v5.2-dev|\
sr3200|\
xd3200)
ath10kcal_extract "art" 20480 2116
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 96b3e650f1..01ac29601d 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -865,6 +865,12 @@ ar71xx_board_detect() {
*"Packet Squirrel")
name="packet-squirrel"
;;
+ *"Oolite V5.2")
+ name="oolite-v5.2"
+ ;;
+ *"Oolite V5.2-Dev")
+ name="oolite-v5.2-dev"
+ ;;
*"PB42")
name="pb42"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index c73dbd49ec..7738db33a7 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -399,6 +399,8 @@ platform_check_image() {
omy-x1|\
onion-omega|\
oolite-v1|\
+ oolite-v5.2|\
+ oolite-v5.2-dev|\
packet-squirrel|\
re355|\
re450|\
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index d49cebf812..c55bdab0e8 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -124,6 +124,7 @@ CONFIG_ATH79=y
# CONFIG_ATH79_MACH_GL_MIFI is not set
# CONFIG_ATH79_MACH_GL_USB150 is not set
# CONFIG_ATH79_MACH_GS_OOLITE_V1 is not set
+# CONFIG_ATH79_MACH_GS_OOLITE_V5_2 is not set
# CONFIG_ATH79_MACH_HIVEAP_121 is not set
# CONFIG_ATH79_MACH_HIWIFI_HC6361 is not set
# CONFIG_ATH79_MACH_HORNET_UB is not set
diff --git a/target/linux/ar71xx/config-4.9 b/target/linux/ar71xx/config-4.9
index c6c5cf3ce3..026d5bb617 100644
--- a/target/linux/ar71xx/config-4.9
+++ b/target/linux/ar71xx/config-4.9
@@ -122,6 +122,7 @@ CONFIG_ATH79=y
# CONFIG_ATH79_MACH_GL_MIFI is not set
# CONFIG_ATH79_MACH_GL_USB150 is not set
# CONFIG_ATH79_MACH_GS_OOLITE_V1 is not set
+# CONFIG_ATH79_MACH_GS_OOLITE_V5_2 is not set
# CONFIG_ATH79_MACH_HIVEAP_121 is not set
# CONFIG_ATH79_MACH_HIWIFI_HC6361 is not set
# CONFIG_ATH79_MACH_HORNET_UB is not set
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index ed2d42e7f1..ec3c329d7a 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -890,6 +890,17 @@ config ATH79_MACH_GS_OOLITE_V1
select ATH79_DEV_USB
select ATH79_DEV_WMAC
+config ATH79_MACH_GS_OOLITE_V5_2
+ bool "GainStrong Oolite V5.2 support"
+ select SOC_QCA953X
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_HIVEAP_121
bool "Aerohive HiveAP-121 support"
select SOC_AR934X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 54f4053b41..62d7317206 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -132,6 +132,7 @@ obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
obj-$(CONFIG_ATH79_MACH_GL_MIFI) += mach-gl-mifi.o
obj-$(CONFIG_ATH79_MACH_GL_USB150) += mach-gl-usb150.o
obj-$(CONFIG_ATH79_MACH_GS_OOLITE_V1) += mach-gs-oolite-v1.o
+obj-$(CONFIG_ATH79_MACH_GS_OOLITE_V5_2) += mach-gs-oolite-v5-2.o
obj-$(CONFIG_ATH79_MACH_HIVEAP_121) += mach-hiveap-121.o
obj-$(CONFIG_ATH79_MACH_HIWIFI_HC6361) += mach-hiwifi-hc6361.o
obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-gs-oolite-v5-2.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-gs-oolite-v5-2.c
new file mode 100644
index 0000000000..64dc4f3345
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-gs-oolite-v5-2.c
@@ -0,0 +1,111 @@
+/*
+ * GainStrong Oolite V5.2 module and development board support
+ *
+ * Copyright (C) 2018 Piotr Dymacz <pepe2k@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "pci.h"
+
+#define GS_OOLITE_V5_2_DEV_GPIO_BTN_RESET 17
+#define GS_OOLITE_V5_2_DEV_GPIO_LED_SYSTEM 13
+
+#define GS_KEYS_POLL_INTERVAL 20 /* msec */
+#define GS_KEYS_DEBOUNCE_INTERVAL (3 * GS_KEYS_POLL_INTERVAL)
+
+#define GS_OOLITE_V5_2_WMAC_CALDATA_OFFSET 0x1000
+
+static const char *gs_oolite_v5_2_part_probes[] = {
+ "tp-link",
+ NULL,
+};
+
+static struct flash_platform_data gs_oolite_v5_2_flash_data = {
+ .part_probes = gs_oolite_v5_2_part_probes,
+};
+
+static struct gpio_led gs_oolite_v5_2_dev_gpio_leds[] __initdata = {
+ {
+ .name = "oolite-v5.2-dev:blue:system",
+ .gpio = GS_OOLITE_V5_2_DEV_GPIO_LED_SYSTEM,
+ .active_low = 0,
+ },
+};
+
+static struct gpio_keys_button gs_oolite_v5_2_dev_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = GS_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = GS_OOLITE_V5_2_DEV_GPIO_BTN_RESET,
+ .active_low = 1,
+ },
+};
+
+static void __init gs_oolite_v5_2_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+ ath79_register_m25p80(&gs_oolite_v5_2_flash_data);
+
+ ath79_setup_ar933x_phy4_switch(false, false);
+
+ ath79_register_mdio(0, 0x0);
+
+ ath79_switch_data.phy4_mii_en = 1;
+ ath79_switch_data.phy_poll_mask |= BIT(4);
+
+ /* LAN */
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+ ath79_init_mac(ath79_eth1_data.mac_addr, art + 6, 0);
+ ath79_register_eth(1);
+
+ /* WAN */
+ ath79_eth0_data.duplex = DUPLEX_FULL;
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.phy_mask = BIT(4);
+ ath79_eth0_data.speed = SPEED_100;
+ ath79_init_mac(ath79_eth0_data.mac_addr, art, 0);
+ ath79_register_eth(0);
+
+ ath79_register_pci();
+ ath79_register_usb();
+ ath79_register_wmac(art + GS_OOLITE_V5_2_WMAC_CALDATA_OFFSET, NULL);
+}
+
+static void __init gs_oolite_v5_2_dev_setup(void)
+{
+ gs_oolite_v5_2_setup();
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(gs_oolite_v5_2_dev_gpio_leds),
+ gs_oolite_v5_2_dev_gpio_leds);
+
+ ath79_register_gpio_keys_polled(-1, GS_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(gs_oolite_v5_2_dev_gpio_keys),
+ gs_oolite_v5_2_dev_gpio_keys);
+}
+
+MIPS_MACHINE(ATH79_MACH_GS_OOLITE_V5_2, "OOLITE-V5-2",
+ "GainStrong Oolite V5.2", gs_oolite_v5_2_setup);
+
+MIPS_MACHINE(ATH79_MACH_GS_OOLITE_V5_2_DEV, "OOLITE-V5-2-DEV",
+ "GainStrong Oolite V5.2-Dev", gs_oolite_v5_2_dev_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index b3250053a6..46bc49458b 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -128,6 +128,8 @@ enum ath79_mach_type {
ATH79_MACH_GL_USB150, /* GL.iNet GL-USB150 */
ATH79_MACH_GS_MINIBOX_V1, /* GainStrong MiniBox V1.0 */
ATH79_MACH_GS_OOLITE_V1, /* GainStrong Oolite V1.0 */
+ ATH79_MACH_GS_OOLITE_V5_2, /* GainStrong Oolite V5.2 */
+ ATH79_MACH_GS_OOLITE_V5_2_DEV, /* GainStrong Oolite V5.2-Dev */
ATH79_MACH_HIVEAP_121, /* Aerohive HiveAP-121*/
ATH79_MACH_HIWIFI_HC6361, /* HiWiFi HC6361 */
ATH79_MACH_HORNET_UB, /* ALFA Networks Hornet-UB */
diff --git a/target/linux/ar71xx/generic/config-default b/target/linux/ar71xx/generic/config-default
index 658e120b96..184087d38a 100644
--- a/target/linux/ar71xx/generic/config-default
+++ b/target/linux/ar71xx/generic/config-default
@@ -95,6 +95,7 @@ CONFIG_ATH79_MACH_GL_INET=y
CONFIG_ATH79_MACH_GL_MIFI=y
CONFIG_ATH79_MACH_GL_USB150=y
CONFIG_ATH79_MACH_GS_OOLITE_V1=y
+CONFIG_ATH79_MACH_GS_OOLITE_V5_2=y
CONFIG_ATH79_MACH_HIWIFI_HC6361=y
CONFIG_ATH79_MACH_HORNET_UB=y
CONFIG_ATH79_MACH_JA76PF=y
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index e1cd21d9cf..37231e0228 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -852,6 +852,25 @@ define Device/oolite-v1
endef
TARGET_DEVICES += oolite-v1
+define Device/oolite-v5.2
+ $(Device/tplink-16mlzma)
+ DEVICE_TITLE := GainStrong Oolite V5.2
+ DEVICE_PACKAGES := ath10k-firmware-qca9887 kmod-ath10k kmod-usb-core kmod-usb2
+ BOARDNAME := OOLITE-V5-2
+ DEVICE_PROFILE := OOLITEV52
+ TPLINK_HWID := 0x3C00010B
+ IMAGES := sysupgrade.bin
+endef
+TARGET_DEVICES += oolite-v5.2
+
+define Device/oolite-v5.2-dev
+ $(Device/oolite-v5.2)
+ DEVICE_TITLE := GainStrong Oolite V5.2-Dev (development board)
+ BOARDNAME := OOLITE-V5-2-DEV
+ DEVICE_PROFILE := OOLITEV52DEV
+endef
+TARGET_DEVICES += oolite-v5.2-dev
+
define Device/omy-g1
$(Device/tplink-16mlzma)
DEVICE_TITLE := OMYlink OMY-G1