aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-11-25 09:51:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-11-25 09:51:33 +0000
commit4292229e9f64b5d2be3f1143c70fe51f1f5f751a (patch)
treede76c19ec0f48147058cd60c7ced020fb3fba87b /target/linux
parent4704478682957b9671bd4408eda14e651320113c (diff)
downloadupstream-4292229e9f64b5d2be3f1143c70fe51f1f5f751a.tar.gz
upstream-4292229e9f64b5d2be3f1143c70fe51f1f5f751a.tar.bz2
upstream-4292229e9f64b5d2be3f1143c70fe51f1f5f751a.zip
ar71xx: use MkImageLzma template for Ubiquiti XM devices
SVN-Revision: 18534
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index b61524ecdb..db57ed4e83 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -141,11 +141,7 @@ endef
ubntxm_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1024k(kernel),6528k(rootfs),256k(cfg)ro,64k(EEPROM)ro,7552k@0x50000(firmware)
define Image/Build/UBNTXM
$(call PatchKernelLzma,$(2),$(3) $(ubntxm_mtdlayout))
- mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
- 0x80060000 \
- -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/vmlinux-$(2).bin.lzma \
- $(KDIR)/vmlinux-$(2).uImage.bin
+ $(call MkImageLzma,$(KDIR)/vmlinux-$(2).bin.lzma,$(KDIR)/vmlinux-$(2).uImage.bin)
dd if=$(KDIR)/vmlinux-$(2).uImage.bin of=$(KDIR)/vmlinux-$(2).uImage bs=1024k conv=sync
-$(STAGING_DIR_HOST)/bin/mkfwimage \
-B $(4) -v $(5).$(6).OpenWrt.$(REVISION) \