aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2007-12-25 12:04:52 +0000
committerJohn Crispin <blogic@openwrt.org>2007-12-25 12:04:52 +0000
commit267a8d131d497dc9738e40466b3bd2146e1ec9fd (patch)
treec4b158fecf8b29bcc57b50f757363476649b0be6 /target/linux
parentc76ba05e35b4f29554041bcb77bf608fbde1d7c7 (diff)
downloadupstream-267a8d131d497dc9738e40466b3bd2146e1ec9fd.tar.gz
upstream-267a8d131d497dc9738e40466b3bd2146e1ec9fd.tar.bz2
upstream-267a8d131d497dc9738e40466b3bd2146e1ec9fd.zip
make ifxmips able to handle platform devices
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9921 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ifxmips/files/arch/mips/ifxmips/Makefile3
-rw-r--r--target/linux/ifxmips/files/arch/mips/ifxmips/board.c68
2 files changed, 70 insertions, 1 deletions
diff --git a/target/linux/ifxmips/files/arch/mips/ifxmips/Makefile b/target/linux/ifxmips/files/arch/mips/ifxmips/Makefile
index eb2c892e8a..86dc423459 100644
--- a/target/linux/ifxmips/files/arch/mips/ifxmips/Makefile
+++ b/target/linux/ifxmips/files/arch/mips/ifxmips/Makefile
@@ -1,4 +1,5 @@
-obj-y := reset.o prom.o setup.o interrupt.o dma-core.o pmu.o
+obj-y := reset.o prom.o setup.o interrupt.o dma-core.o pmu.o board.o
+#mps/
obj-$(CONFIG_PCI) += pci.o
obj-$(CONFIG_KGDB) += kgdb_serial.o
diff --git a/target/linux/ifxmips/files/arch/mips/ifxmips/board.c b/target/linux/ifxmips/files/arch/mips/ifxmips/board.c
new file mode 100644
index 0000000000..017a8a62b7
--- /dev/null
+++ b/target/linux/ifxmips/files/arch/mips/ifxmips/board.c
@@ -0,0 +1,68 @@
+/*
+ * arch/mips/ifxmips/board.c
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
+ *
+ * Copyright (C) 2007 John Crispin <blogic@openwrt.org>
+ *
+ */
+
+#include <linux/autoconf.h>
+#include <linux/init.h>
+#include <linux/module.h>
+#include <linux/types.h>
+#include <linux/string.h>
+#include <linux/mtd/physmap.h>
+#include <linux/platform_device.h>
+#include <linux/kernel.h>
+#include <linux/reboot.h>
+#include <asm/bootinfo.h>
+#include <asm/reboot.h>
+#include <asm/time.h>
+#include <asm/irq.h>
+#include <asm/io.h>
+
+#define MAX_IFXMIPS_DEVS 5
+
+static struct platform_device *ifxmips_devs[MAX_IFXMIPS_DEVS];
+
+static struct platform_device ifxmips_led[] =
+{
+ {
+ .id = 0,
+ .name = "ifxmips_led",
+ },
+};
+
+int __init ifxmips_init_devices(void)
+{
+ /*
+ * This is where we detect what chip we are running on
+ * Currently we support 3 chips
+ * 1.) Danube
+ * 2.) Twinpass (Danube without dsl phy)
+ * 3.) KDbg74 (used for debuging)
+ */
+
+ int dev = 0;
+
+ /* the following devices are generic for all targets */
+
+ ifxmips_devs[dev++] = ifxmips_led;
+
+ return platform_add_devices(ifxmips_devs, dev);
+}
+
+arch_initcall(ifxmips_init_devices);