aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-02-11 10:17:38 +0000
committerJohn Crispin <blogic@openwrt.org>2015-02-11 10:17:38 +0000
commit0e26998162921c65cbfe2814e500c81ca7b50dad (patch)
treeb9618bfe258a541fb3f3eee316eab2dd3b860f39 /target/linux
parenta530948b3a6541f9a58f2f08e2fc06be75d60669 (diff)
downloadupstream-0e26998162921c65cbfe2814e500c81ca7b50dad.tar.gz
upstream-0e26998162921c65cbfe2814e500c81ca7b50dad.tar.bz2
upstream-0e26998162921c65cbfe2814e500c81ca7b50dad.zip
lantiq: fix VG3503J partition table for newer kernels
the kernel has increased and does not fit into the 1,5MB anymore. Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44391 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/lantiq/dts/VG3503J.dtsi4
-rw-r--r--target/linux/lantiq/image/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/lantiq/dts/VG3503J.dtsi b/target/linux/lantiq/dts/VG3503J.dtsi
index 3e6bab5dd3..cebc4a49ca 100644
--- a/target/linux/lantiq/dts/VG3503J.dtsi
+++ b/target/linux/lantiq/dts/VG3503J.dtsi
@@ -28,12 +28,12 @@
partition@20000 {
label = "kernel";
- reg = <0x20000 0x180000>;
+ reg = <0x20000 0x300000>;
};
partition@1a0000 {
label = "rootfs";
- reg = <0x1a0000 0x5a0000>;
+ reg = <0x1a0000 0x420000>;
};
partition@740000 {
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 82f0e6f327..08d80ecb1d 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -156,7 +156,7 @@ endif
endef
define Image/BuildLoader/squashfs
- dd if=$(KDIR)/loader-$(2).bin of=$(KDIR)/loader-$(2).bin.padded bs=1536k conv=sync
+ dd if=$(KDIR)/loader-$(2).bin of=$(KDIR)/loader-$(2).bin.padded bs=3072k conv=sync
cat $(KDIR)/loader-$(2).bin.padded $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
$(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image)
endef