aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-08-29 21:23:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-08-29 21:23:51 +0000
commitf75c26a62c54760c343c489a65122983f466175d (patch)
treea353dc338a69065d574164c5218c08b3bb363828 /target/linux
parent952ae8606240a8fda7484f3c4a5aa451dc8c32b5 (diff)
downloadupstream-f75c26a62c54760c343c489a65122983f466175d.tar.gz
upstream-f75c26a62c54760c343c489a65122983f466175d.tar.bz2
upstream-f75c26a62c54760c343c489a65122983f466175d.zip
brcm47xx: fix padding of trx images, padjffs2 does not work properly on empty files by default
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28125 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/brcm47xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index bc2ff3a8f1..f7cce16995 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -20,7 +20,7 @@ define Image/Prepare
clean install
echo -ne "\\x00" >> $(KDIR)/loader.gz
rm -f $(KDIR)/fs_mark
- touch $(KDIR)/fs_mark
+ echo -ne '\xde\xad\xc0\xde' > $(KDIR)/fs_mark
$(call prepare_generic_squashfs,$(KDIR)/fs_mark)
endef