aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-07 11:40:45 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-07 11:40:45 +0000
commitee2f2c1138091cf7804d0ece16cc4bf8813db4e2 (patch)
tree43bf382901460ee423711e4327d792de4427b8b8 /target/linux
parentbc12e556fbecdc05374fd81e8c28d11eeb5367c0 (diff)
downloadupstream-ee2f2c1138091cf7804d0ece16cc4bf8813db4e2.tar.gz
upstream-ee2f2c1138091cf7804d0ece16cc4bf8813db4e2.tar.bz2
upstream-ee2f2c1138091cf7804d0ece16cc4bf8813db4e2.zip
ar71xx: use the lzma loader for the WRT160NL
Partition layout before: 0x000000040000-0x0000001a0000 : "kernel" 0x0000001a0000-0x0000007e0000 : "rootfs" mtd: partition "rootfs" set to be root filesystem mtd: partition "rootfs_data" created automatically, ofs=0x350000, len=0x490000 0x000000350000-0x0000007e0000 : "rootfs_data" after: 0x000000040000-0x000000140000 : "kernel" 0x000000140000-0x0000007e0000 : "rootfs" mtd: partition "rootfs" set to be root filesystem mtd: partition "rootfs_data" created automatically, ofs=0x2f0000, len=0x4f0000 0x0000002f0000-0x0000007e0000 : "rootfs_data" Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37915 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index ac9c8b87e9..98f364dc0b 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -618,8 +618,8 @@ define Image/Build/TPLINK-LZMA/initramfs
-o $(call imgname,$(1),$(2))-uImage.bin
endef
-
-Image/Build/CyberTAN/buildkernel=$(call MkuImageGzip,$(2),$(3))
+Image/Build/CyberTAN/loader=$(call Image/BuildLoader,$(1),gz,$(2),0x80060000)
+Image/Build/CyberTAN/buildkernel=$(call MkuImage,gzip,,$(KDIR)/loader-$(2).gz,$(KDIR_TMP)/vmlinux-$(2).uImage)
define Image/Build/CyberTAN
$(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR_TMP)/vmlinux-$(2).uImage \