aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-24 18:12:52 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-24 18:12:52 +0000
commitb73720eae8c4d9c7adbe4817177c2f08be34108c (patch)
tree114326ae141d902369360bc643f1c5eab7f806b2 /target/linux
parent2badccb73ecc337f899f43f0be80f794e44b76d8 (diff)
downloadupstream-b73720eae8c4d9c7adbe4817177c2f08be34108c.tar.gz
upstream-b73720eae8c4d9c7adbe4817177c2f08be34108c.tar.bz2
upstream-b73720eae8c4d9c7adbe4817177c2f08be34108c.zip
lantiq: remove deprecated jffs2_nand configuration
As far as I am aware, amongst the lantiq boards, jffs2_nand was only used on the BTHOMEHUBV2B. Ubi-related modifications to the device tree for that board mean that the resulting jffs2 images no longer work, and are no longer required anyway. So I suggest removing the related configuration, which this patch does. If anyone else is using jffs2_nand on a lantiq target please speak up! Incidentally, for a jffs2 rootfs partition concatenated to the kernel image to be recognised and mounted correctly on nand this patch or something equivalent is required: http://patchwork.openwrt.org/patch/5110/ It is marked as accepted in patchwork but doesn't seem to have been committed. As far as I am concerned it too is deprecated. Signed-off-by: Ben Mulvihill <ben.mulvihill@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41312 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/lantiq/image/Makefile8
-rw-r--r--target/linux/lantiq/xway/target.mk2
2 files changed, 1 insertions, 9 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 3af3d999b3..7d95061b54 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -12,7 +12,6 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE = 64k 128k 256k
-NAND_BLOCKSIZE = 512:16k
LOADER_MAKE := $(NO_TRACE_MAKE) -C lzma-loader KDIR=$(KDIR)
@@ -171,13 +170,6 @@ define Image/Build/jffs2-256k
cat $(KDIR)/uImage-$(2)-$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
endef
-define Image/Build/jffs2-nand-512-16k
- dd if=$(KDIR)/uImage-$(2) of=$(KDIR)/uImage-$(2)-$(1) bs=16k conv=sync
- $(CP) $(KDIR)/uImage-$(2)-$(1) $(BIN_DIR)/uImage-$(2)-$(1)
- $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/root-$(2)-$(1)
- cat $(KDIR)/uImage-$(2)-$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
-endef
-
define Image/Build/ubifs
ifneq ($($(PROFILE)_UBIFS_OPTS),)
diff --git a/target/linux/lantiq/xway/target.mk b/target/linux/lantiq/xway/target.mk
index e8a287412b..0cc3f8ae27 100644
--- a/target/linux/lantiq/xway/target.mk
+++ b/target/linux/lantiq/xway/target.mk
@@ -1,7 +1,7 @@
ARCH:=mips
SUBTARGET:=xway
BOARDNAME:=XWAY
-FEATURES:=squashfs atm mips16 jffs2_nand nand ubifs
+FEATURES:=squashfs atm mips16 nand ubifs
CPU_TYPE:=34kc
CPU_SUBTYPE:=dsp