aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2010-03-18 11:20:35 +0000
committerJohn Crispin <blogic@openwrt.org>2010-03-18 11:20:35 +0000
commita15d84be281565b09454fd86b1e64fbde2d271c6 (patch)
tree42b3016f8e3790f453b1c969019874b00dc8e743 /target/linux
parentc7eb5514a407e6eb375e00dd304d53b155cc1c0d (diff)
downloadupstream-a15d84be281565b09454fd86b1e64fbde2d271c6.tar.gz
upstream-a15d84be281565b09454fd86b1e64fbde2d271c6.tar.bz2
upstream-a15d84be281565b09454fd86b1e64fbde2d271c6.zip
[ifxmips] Also build jffs2 images with 128k eraseblock size, signed off by Ithamar R. Adema
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20267 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ifxmips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ifxmips/image/Makefile b/target/linux/ifxmips/image/Makefile
index 15e0bc5dc3..ac887c4e49 100644
--- a/target/linux/ifxmips/image/Makefile
+++ b/target/linux/ifxmips/image/Makefile
@@ -27,6 +27,11 @@ define Image/Build/jffs2-64k
cat $(KDIR)/uImage.$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).image
endef
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/uImage of=$(KDIR)/uImage.$(1) bs=128k conv=sync
+ cat $(KDIR)/uImage.$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).image
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
endef