aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-08-01 07:10:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-08-01 07:10:16 +0000
commit8df629478bf0cf77fdfa88fd8de0e14979d37b17 (patch)
tree62a574ceff38f0f98be7ba2843ca8d54146e8bd2 /target/linux
parent3725eb6da034699cd8cfa4158035748e3deb35c3 (diff)
downloadupstream-8df629478bf0cf77fdfa88fd8de0e14979d37b17.tar.gz
upstream-8df629478bf0cf77fdfa88fd8de0e14979d37b17.tar.bz2
upstream-8df629478bf0cf77fdfa88fd8de0e14979d37b17.zip
cns3xxx: fix building initramfs and non-initramfs together
Signed-off-by: Felix Fietkau <nbd@openwrt.org> Backport of r41922 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@41923 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/cns3xxx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/cns3xxx/image/Makefile b/target/linux/cns3xxx/image/Makefile
index ad3789adf4..c86b642e6c 100644
--- a/target/linux/cns3xxx/image/Makefile
+++ b/target/linux/cns3xxx/image/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/Prepare
- mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/uImage
+ mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage $(KDIR)/uImage
endef
# Build sysupgrade image