aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-10-28 06:47:56 +0000
committerJohn Crispin <blogic@openwrt.org>2013-10-28 06:47:56 +0000
commit3e985818da100dee9db10e221235b4c885641591 (patch)
treeb680c3ca630bd7f548593b5a3fa509f8e44ef7b7 /target/linux
parent465cee98bd5764fc718f50689c436a8a72b825ae (diff)
downloadupstream-3e985818da100dee9db10e221235b4c885641591.tar.gz
upstream-3e985818da100dee9db10e221235b4c885641591.tar.bz2
upstream-3e985818da100dee9db10e221235b4c885641591.zip
ralink: add package for mt7620 sdhci
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38553 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/modules.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 33b5c23697..adf5e0230d 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -25,6 +25,19 @@ endef
$(eval $(call KernelPackage,usb-rt305x-dwc_otg))
+OTHER_MENU:=Other modules
+define KernelPackage/sdhci-mt7620
+ SUBMENU:=Other modules
+ TITLE:=MT7620 SDCI
+ DEPENDS:=@TARGET_ramips_mt7620a +kmod-sdhci
+ KCONFIG:= \
+ CONFIG_MMC_SDHCI_MT7620
+ FILES:= \
+ $(LINUX_DIR)/drivers/mmc/host/sdhci-mt7620.ko
+ AUTOLOAD:=$(call AutoProbe,sdhci-mt7620,1)
+endef
+
+$(eval $(call KernelPackage,sdhci-mt7620))
I2C_RALINK_MODULES:= \
CONFIG_I2C_RALINK:drivers/i2c/busses/i2c-ralink