aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-23 09:09:16 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-23 09:09:16 +0000
commitac21ef3f084e3458ea9fff22b1091c161b1755b6 (patch)
treefac130b41304a70255ceb4d523cef48e8fea65af /target/linux
parent7e158d630724ce783163480880a27adee5854c9e (diff)
downloadupstream-ac21ef3f084e3458ea9fff22b1091c161b1755b6.tar.gz
upstream-ac21ef3f084e3458ea9fff22b1091c161b1755b6.tar.bz2
upstream-ac21ef3f084e3458ea9fff22b1091c161b1755b6.zip
[avr32] generate LZMA compressed uImage as well
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11249 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/avr32/image/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/target/linux/avr32/image/Makefile b/target/linux/avr32/image/Makefile
index cbaf07dfb3..2cef2653bf 100644
--- a/target/linux/avr32/image/Makefile
+++ b/target/linux/avr32/image/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -22,6 +22,14 @@ endef
define Image/BuildKernel
cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+ mkimage -A avr32 -O linux -T kernel -a 0x10000000 -C lzma \
+ -e 0x90000000 \
+ -n 'OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux.lzma $(KDIR)/uImage-lzma
+
+ cp $(KDIR)/uImage-lzma $(BIN_DIR)/openwrt-$(BOARD)-uImage-lzma
endef
define Image/Build