aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-17 10:03:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-17 10:03:27 +0000
commit9497e9a538c1a28868f7c1b01b65147e1ce325bf (patch)
tree7d2a72a830138b61cb4a2206c0120af160293ef0 /target/linux
parent440097882ec693ab5f0f327e6f7fd34c7a407369 (diff)
downloadupstream-9497e9a538c1a28868f7c1b01b65147e1ce325bf.tar.gz
upstream-9497e9a538c1a28868f7c1b01b65147e1ce325bf.tar.bz2
upstream-9497e9a538c1a28868f7c1b01b65147e1ce325bf.zip
another svn-related fix
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2116 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/package/openwrt/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/package/openwrt/Makefile b/target/linux/package/openwrt/Makefile
index 82ceb3d906..d1f8673515 100644
--- a/target/linux/package/openwrt/Makefile
+++ b/target/linux/package/openwrt/Makefile
@@ -36,7 +36,7 @@ $(IDIR_OPENWRT):
$(SED) s,base-files-arch,base-files-$(BOARD)-$(KERNEL),g $(IDIR_OPENWRT)/CONTROL/control
$(IPKG_OPENWRT): $(IDIR_OPENWRT)
- [ -d files/$(BOARD)-$(KERNEL) ] && cp -a files/$(BOARD)-$(KERNEL)/* $(IDIR_OPENWRT)/
+ [ -d files/$(BOARD)-$(KERNEL) ] && cp -fpR files/$(BOARD)-$(KERNEL)/* $(IDIR_OPENWRT)/
find $(IDIR_OPENWRT) -name CVS | xargs rm -rf
find $(IDIR_OPENWRT) -name .svn | xargs rm -rf
$(RSTRIP) $(IDIR_OPENWRT)
@@ -47,4 +47,4 @@ install: compile
compile: install-dev $(IPKG_OPENWRT)
install-dev:
mkdir -p $(STAGING_DIR)/usr/include
- cp -a ./include/* $(STAGING_DIR)/usr/include/
+ cp -fpR ./include/[a-z]* $(STAGING_DIR)/usr/include/