aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-28 11:54:24 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-28 11:54:24 +0000
commit391058b15b7a503aa56f4595ae828185e1f747fc (patch)
tree3d154da4b1adeda6d6d41eb52bf8e31dbad18f81 /target/linux
parent629cba4013b0465e4aac7815d256950ca68c7429 (diff)
downloadupstream-391058b15b7a503aa56f4595ae828185e1f747fc.tar.gz
upstream-391058b15b7a503aa56f4595ae828185e1f747fc.tar.bz2
upstream-391058b15b7a503aa56f4595ae828185e1f747fc.zip
ar71xx: switch to 2.6.32
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19359 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/patches-2.6.32/003-ar71xx_usb_host.patch2
-rw-r--r--target/linux/ar71xx/patches-2.6.32/110-usb-ehci-add-war-for-synopsys-hc-bug.patch2
3 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index b5184b64dc..4a153e8374 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Atheros AR71xx/AR7240/AR913x
FEATURES:=squashfs jffs2 tgz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-LINUX_VERSION:=2.6.30.10
+LINUX_VERSION:=2.6.32.6
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/patches-2.6.32/003-ar71xx_usb_host.patch b/target/linux/ar71xx/patches-2.6.32/003-ar71xx_usb_host.patch
index 08559bccbe..0a428c78fe 100644
--- a/target/linux/ar71xx/patches-2.6.32/003-ar71xx_usb_host.patch
+++ b/target/linux/ar71xx/patches-2.6.32/003-ar71xx_usb_host.patch
@@ -30,7 +30,7 @@
depends on USB_OHCI_HCD && (STB03xxx || PPC_MPC52xx)
--- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c
-@@ -1140,6 +1140,11 @@ MODULE_LICENSE ("GPL");
+@@ -1141,6 +1141,11 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ehci_atmel_driver
#endif
diff --git a/target/linux/ar71xx/patches-2.6.32/110-usb-ehci-add-war-for-synopsys-hc-bug.patch b/target/linux/ar71xx/patches-2.6.32/110-usb-ehci-add-war-for-synopsys-hc-bug.patch
index 91af1ac607..18994d0839 100644
--- a/target/linux/ar71xx/patches-2.6.32/110-usb-ehci-add-war-for-synopsys-hc-bug.patch
+++ b/target/linux/ar71xx/patches-2.6.32/110-usb-ehci-add-war-for-synopsys-hc-bug.patch
@@ -1,6 +1,6 @@
--- a/drivers/usb/host/ehci-q.c
+++ b/drivers/usb/host/ehci-q.c
-@@ -1167,6 +1167,9 @@ static void end_unlink_async (struct ehc
+@@ -1172,6 +1172,9 @@ static void end_unlink_async (struct ehc
ehci->reclaim = NULL;
start_unlink_async (ehci, next);
}