aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-01-31 16:01:20 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-01-31 16:01:20 +0000
commit2f386223ed7fd0d9e5c9f7044e98e72d4fe61f71 (patch)
treef85a42a9344781b176d14870033442cc1e2b4ceb /target/linux
parent07cb5e56858239307685acfbe48f438cd36596c8 (diff)
downloadupstream-2f386223ed7fd0d9e5c9f7044e98e72d4fe61f71.tar.gz
upstream-2f386223ed7fd0d9e5c9f7044e98e72d4fe61f71.tar.bz2
upstream-2f386223ed7fd0d9e5c9f7044e98e72d4fe61f71.zip
[brcm63xx] add support for user9102 boards (#4537)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14305 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c22
-rw-r--r--target/linux/brcm63xx/image/Makefile2
2 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c b/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
index 7dd77f0082..76dd54013f 100644
--- a/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
@@ -184,6 +184,27 @@ static struct board_info __initdata board_DV201AMR = {
.has_ehci0 = 1,
};
+static struct board_info __initdata board_96348gw_a = {
+ .name = "96348GW-A",
+ .expected_cpu_id = 0x6348,
+
+ .has_enet0 = 1,
+ .has_enet1 = 1,
+ .has_pci = 1,
+
+ .enet0 = {
+ .has_phy = 1,
+ .use_internal_phy = 1,
+ },
+ .enet1 = {
+ .force_speed_100 = 1,
+ .force_duplex_full = 1,
+ },
+
+ .has_ohci0 = 1,
+};
+
+
#endif
/*
@@ -253,6 +274,7 @@ static const struct board_info __initdata *bcm963xx_boards[] = {
&board_96348gw_11,
&board_FAST2404,
&board_DV201AMR,
+ &board_96348gw_a,
#endif
#ifdef CONFIG_BCM63XX_CPU_6358
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index c9a728bbf2..6cb7a34c01 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -96,6 +96,8 @@ define Image/Build
$(call Image/Build/CFE,$(1),96348GW-11,6348)
# Davolink DV201AMR
$(call Image/Build/CFEOLD,$(1),DV201AMR,6348)
+ # USR 9108
+ $(call Image/Build/CFE,$(1),96348GW-A,6348)
# DG834GT
$(call Image/Build/CFE,$(1),96348GW-10,6348)
# Sagem F@ST2404