aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-04-26 18:27:47 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-04-26 18:27:47 +0000
commit0656f01bd8b5dd902063ff98c051b808240b156d (patch)
tree9c14cbcfb1e79b3458e547bb77e58551dd685475 /target/linux
parentc2a7abf19cafc8d9afdb7c55f5c817f29f3f58cd (diff)
downloadupstream-0656f01bd8b5dd902063ff98c051b808240b156d.tar.gz
upstream-0656f01bd8b5dd902063ff98c051b808240b156d.tar.bz2
upstream-0656f01bd8b5dd902063ff98c051b808240b156d.zip
ar71xx: create separate 'factory' and 'sysupgrade' images for the WRT160NL
The 'factory' image requires the garbage at the end of the image. Flashing from the original web interface does not work without that. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21168 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index cd066f78ed..a5f02703c9 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -320,7 +320,10 @@ define Image/Build/CyberTAN
-x 32 -a 0x10000 -x -32 -f $(KDIR)/root.$(1)
-$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) \
-i $(KDIR)/image.tmp \
- -o $(call imgname,$(1),$(2)).bin
+ -o $(call imgname,$(1),$(2))-sysupgrade.bin
+ -$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) -g \
+ -i $(KDIR)/image.tmp \
+ -o $(call imgname,$(1),$(2))-factory.bin
rm $(KDIR)/image.tmp
endef