aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/zynq/Makefile
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2018-09-03 22:40:02 -0300
committerJohn Crispin <john@phrozen.org>2018-09-10 08:55:39 +0200
commit412763c81204d0fda0ebb753cb1da78aada34c5b (patch)
tree0c533350af007cbab1c3c6246e4211282f12e38f /target/linux/zynq/Makefile
parentd6501467e7aac5b7b0831363753da4a86f33f182 (diff)
downloadupstream-412763c81204d0fda0ebb753cb1da78aada34c5b.tar.gz
upstream-412763c81204d0fda0ebb753cb1da78aada34c5b.tar.bz2
upstream-412763c81204d0fda0ebb753cb1da78aada34c5b.zip
zynq: add sdcard image support
Implement the generation of sdcard images with ext4 or squashfs + f2fs overlay, but only enable the latter automatically Additionally, add mkf2fs and e2fsprogs to default packages to manipulate ext4 and f2fs filesystems Finally, disable the automatic generation of initramfs and rootfs.tar.gz images, as they are no longer required (they can still be selected in menuconfig) Signed-off-by: Luis Araneda <luaraneda@gmail.com>
Diffstat (limited to 'target/linux/zynq/Makefile')
-rw-r--r--target/linux/zynq/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/zynq/Makefile b/target/linux/zynq/Makefile
index 6c0ca921d5..6193675088 100644
--- a/target/linux/zynq/Makefile
+++ b/target/linux/zynq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=zynq
BOARDNAME:=Xilinx Zynq 7000 SoCs
-FEATURES:=fpu gpio rtc usb usbgadget ramdisk targz
+FEATURES:=fpu gpio rtc usb usbgadget boot-part rootfs-part squashfs
CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=neon
MAINTAINER:=Jason Wu <jason.wu.misc@gmail.com>
@@ -26,6 +26,6 @@ include $(INCLUDE_DIR)/target.mk
KERNELNAME:=Image dtbs
-DEFAULT_PACKAGES += uboot-envtools
+DEFAULT_PACKAGES += uboot-envtools mkf2fs e2fsprogs
$(eval $(call BuildTarget))