aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/xburst/patches-2.6.32
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-03-05 04:21:41 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-03-05 04:21:41 +0000
commit01ed21fc16e8068c7d230945983a38a43570e6c3 (patch)
treee8c36995cd9fe7d8eee72343149adc2cf06558a7 /target/linux/xburst/patches-2.6.32
parentf1afccc2d9b644d94efceb99a9f30f4ec4c5a7fb (diff)
downloadupstream-01ed21fc16e8068c7d230945983a38a43570e6c3.tar.gz
upstream-01ed21fc16e8068c7d230945983a38a43570e6c3.tar.bz2
upstream-01ed21fc16e8068c7d230945983a38a43570e6c3.zip
Add support for the n516
SVN-Revision: 19987
Diffstat (limited to 'target/linux/xburst/patches-2.6.32')
-rw-r--r--target/linux/xburst/patches-2.6.32/800-n5x6-lpc.patch (renamed from target/linux/xburst/patches-2.6.32/800-n526-lpc.patch)13
1 files changed, 11 insertions, 2 deletions
diff --git a/target/linux/xburst/patches-2.6.32/800-n526-lpc.patch b/target/linux/xburst/patches-2.6.32/800-n5x6-lpc.patch
index df81b64ba3..169bc84ad5 100644
--- a/target/linux/xburst/patches-2.6.32/800-n526-lpc.patch
+++ b/target/linux/xburst/patches-2.6.32/800-n5x6-lpc.patch
@@ -10,10 +10,18 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/800-n5
--- a/drivers/i2c/chips/Kconfig
+++ b/drivers/i2c/chips/Kconfig
-@@ -26,4 +26,13 @@ config SENSORS_TSL2550
+@@ -26,4 +26,21 @@ config SENSORS_TSL2550
This driver can also be built as a module. If so, the module
will be called tsl2550.
++config N516_LPC
++ tristate "N516 keys & power controller"
++ depends on I2C
++ depends on INPUT
++ depends on POWER_SUPPLY
++ help
++ N516 keyboard & power controller driver
++
+config N526_LPC
+ tristate "N526 LPC934 coprocessor"
+ depends on JZ4740_N526
@@ -26,10 +34,11 @@ Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/800-n5
endmenu
--- a/drivers/i2c/chips/Makefile
+++ b/drivers/i2c/chips/Makefile
-@@ -12,6 +12,7 @@
+@@ -12,6 +12,8 @@
obj-$(CONFIG_DS1682) += ds1682.o
obj-$(CONFIG_SENSORS_TSL2550) += tsl2550.o
++obj-$(CONFIG_N516_LPC) += n516-lpc.o
+obj-$(CONFIG_N526_LPC) += n526-lpc.o
ifeq ($(CONFIG_I2C_DEBUG_CHIP),y)