aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/xburst/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-05-24 17:23:41 +0200
committerJohn Crispin <john@phrozen.org>2018-05-24 17:24:31 +0200
commitfa0275bd90ce913de57330c9abbe594703d589c6 (patch)
treef9864b2862c06f8302774e817b587644e66d6da9 /target/linux/xburst/modules.mk
parent76ba98d9b0b6e06bb7e843207654223cb62518d6 (diff)
downloadupstream-fa0275bd90ce913de57330c9abbe594703d589c6.tar.gz
upstream-fa0275bd90ce913de57330c9abbe594703d589c6.tar.bz2
upstream-fa0275bd90ce913de57330c9abbe594703d589c6.zip
target/linux: drop anything not on v4.9 or v4.14
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/xburst/modules.mk')
-rw-r--r--target/linux/xburst/modules.mk40
1 files changed, 0 insertions, 40 deletions
diff --git a/target/linux/xburst/modules.mk b/target/linux/xburst/modules.mk
deleted file mode 100644
index 95cebdad6a..0000000000
--- a/target/linux/xburst/modules.mk
+++ /dev/null
@@ -1,40 +0,0 @@
-
-
-SOUND_MENU:=Sound Support
-
-define KernelPackage/sound-soc-jz4740
- SUBMENU:=$(SOUND_MENU)
- DEPENDS:=kmod-sound-soc-core @TARGET_xburst @BROKEN
- TITLE:=JZ4740 SoC sound support
- KCONFIG:=CONFIG_SND_JZ4740_SOC CONFIG_SND_JZ4740_SOC_I2S
- FILES:= \
- $(LINUX_DIR)/sound/soc/jz4740/snd-soc-jz4740.ko \
- $(LINUX_DIR)/sound/soc/jz4740/snd-soc-jz4740-i2s.ko
- AUTOLOAD:=$(call AutoLoad,60,snd-soc-jz4740 snd-soc-jz4740-i2s)
-endef
-
-define KernelPackage/sound-soc-jz4740-codec
- SUBMENU:=$(SOUND_MENU)
- DEPENDS:=kmod-sound-soc-core @TARGET_xburst @BROKEN
- TITLE:=JZ4740 SoC internal codec support
- KCONFIG:=CONFIG_SND_SOC_JZ4740_CODEC
- FILES:=$(LINUX_DIR)/sound/soc/codecs/snd-soc-jz4740-codec.ko
- AUTOLOAD:=$(call AutoLoad,60,snd-soc-jz4740-codec)
-endef
-
-define KernelPackage/sound-soc-xburst/default
- SUBMENU:=$(SOUND_MENU)
- DEPENDS:=kmod-sound-soc-jz4740 kmod-sound-soc-jz4740-codec @TARGET_xburst_$(if $(4),$(4),$(3)) @BROKEN
- TITLE:=$(1) sound support
- KCONFIG:=CONFIG_SND_JZ4740_SOC_$(2)
- FILES:=$(LINUX_DIR)/sound/soc/jz4740/snd-soc-$(3).ko
- AUTOLOAD:=$(call AutoLoad,65,snd-soc-$(3))
-endef
-
-define KernelPackage/sound-soc-qilb60
-$(call KernelPackage/sound-soc-xburst/default,QI NanoNote,QI_LB60,qi-lb60,qi_lb60)
-endef
-
-$(eval $(call KernelPackage,sound-soc-jz4740))
-$(eval $(call KernelPackage,sound-soc-jz4740-codec))
-$(eval $(call KernelPackage,sound-soc-qilb60))