aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/xburst/Makefile
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-01-11 04:44:45 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-01-11 04:44:45 +0000
commit541158d5ad4a941d927a397737b6588d2e4db22d (patch)
treee49a97f18123413611824b8993e9acff9d681bae /target/linux/xburst/Makefile
parentdb06ca593b3d80ec514ecb2b20d49e3638cd3f0b (diff)
downloadupstream-541158d5ad4a941d927a397737b6588d2e4db22d.tar.gz
upstream-541158d5ad4a941d927a397737b6588d2e4db22d.tar.bz2
upstream-541158d5ad4a941d927a397737b6588d2e4db22d.zip
Merge xburst target.
SVN-Revision: 19098
Diffstat (limited to 'target/linux/xburst/Makefile')
-rw-r--r--target/linux/xburst/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
new file mode 100644
index 0000000000..7043be021c
--- /dev/null
+++ b/target/linux/xburst/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=xburst
+BOARDNAME:=XBurst JZ47x0
+FEATURES:=jffs2 tgz ubifs
+
+LINUX_VERSION:=2.6.32
+
+DEVICE_TYPE=other
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=uImage
+
+DEFAULT_PACKAGES += gpioctl
+
+define Target/Description
+ Build firmware images for XBurst JZ47x0 based boards.
+endef
+
+$(eval $(call BuildTarget))