aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-05-01 14:10:25 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-05-07 14:31:22 +0200
commitd022451906915c1bf4e36cbee723f323bbb659d1 (patch)
tree064ad1e259722e7db1faee0eaeca500b6d058aee /target/linux/x86
parentafcb6b1524e4987c9b6ed9f870f40e2ae8ddb368 (diff)
downloadupstream-d022451906915c1bf4e36cbee723f323bbb659d1.tar.gz
upstream-d022451906915c1bf4e36cbee723f323bbb659d1.tar.bz2
upstream-d022451906915c1bf4e36cbee723f323bbb659d1.zip
x86: add ib700wdt module for x86 qemu watchdogs
QEMU+Libvirt can emulate the ib700wdt watchdogs which due to its I/O-Port mapping makes it x86 specific. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/modules.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index fcf8dfcdff..a57a470e8d 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -67,6 +67,24 @@ endef
$(eval $(call KernelPackage,sp5100-tco))
+define KernelPackage/ib700-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=IB700 SBC Watchdog Timer
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_IB700_WDT
+ FILES:=$(LINUX_DIR)/drivers/watchdog/ib700wdt.ko
+ AUTOLOAD:=$(call AutoLoad,50,ib700wdt,1)
+endef
+
+define KernelPackage/ib700-wdt/description
+ Kernel module for the hardware watchdog on the IB700 Single
+ Board Computer produced by TMC Technology (www.tmc-uk.com).
+ Also used by QEMU/libvirt.
+endef
+
+$(eval $(call KernelPackage,ib700-wdt))
+
+
define KernelPackage/pcengines-apuv2
SUBMENU:=$(OTHER_MENU)
TITLE:=PC Engines APUv2/3 front button and LEDs driver