aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-03-20 00:10:58 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-03-21 10:36:00 +0000
commit30a24882900d41a04eec4db5e3cdbe4026d32aeb (patch)
tree92232d01e1603902b5b8e31d3070352ab84057dc /target/linux/x86
parent33cc7e763b1223585d38d3a6f87f48f7e54ff4e8 (diff)
downloadupstream-30a24882900d41a04eec4db5e3cdbe4026d32aeb.tar.gz
upstream-30a24882900d41a04eec4db5e3cdbe4026d32aeb.tar.bz2
upstream-30a24882900d41a04eec4db5e3cdbe4026d32aeb.zip
x86: allow non gzipped images
The previous image generation code would always gzipped images. This patch changes the behaviour and only compresses images when selected in menuconfig. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index dfa1742d5a..c01065f8e6 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -95,10 +95,15 @@ endef
DEVICE_VARS += GRUB2_VARIANT
define Device/Default
ARTIFACT/image.iso := grub-config iso | iso
- IMAGES := combined.img.gz
+ IMAGE/combined.img := append-rootfs | pad-extra 128k | grub-config pc | combined | grub-install
IMAGE/combined.img.gz := append-rootfs | pad-extra 128k | grub-config pc | combined | grub-install | gzip
IMAGE/combined.vdi := append-rootfs | pad-extra 128k | grub-config pc | combined | grub-install | qemu-image vdi
IMAGE/combined.vmdk := append-rootfs | pad-extra 128k | grub-config pc | combined | grub-install | qemu-image vmdk
+ ifeq ($(CONFIG_TARGET_IMAGES_GZIP),y)
+ IMAGES := combined.img.gz
+ else
+ IMAGES := combined.img
+ endif
KERNEL := kernel-bin
KERNEL_INSTALL := 1
KERNEL_NAME := bzImage