aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorJohn Sommerville <jsommerville@untangle.com>2019-09-27 14:09:10 -0600
committerHauke Mehrtens <hauke@hauke-m.de>2019-12-23 00:22:07 +0100
commit6041eb9547be49edaa6c2ecd5dd77e8a9e067244 (patch)
treed7cd7c7fbc69d8e3c945aa0ab1b540b019f09389 /target/linux/x86
parent9e2e48ff31cea669cfc9c1476f49b815ea9ac1b1 (diff)
downloadupstream-6041eb9547be49edaa6c2ecd5dd77e8a9e067244.tar.gz
upstream-6041eb9547be49edaa6c2ecd5dd77e8a9e067244.tar.bz2
upstream-6041eb9547be49edaa6c2ecd5dd77e8a9e067244.zip
build: build proper VMDK formats for ESXI 6.5
VMWare ESXI 6.5 and above is not compatible with subformat=monolithicSparse (The default qemu-img convert -O VMDK option). Monolithic Sparse vmdk can be imported, but issues occur when running sysupgrade with new images and other tasks that modify the file system (issues like Kernel panics, reboot loops, sometimes crashing the Host ESXI box). This change creates an additional VMDK output file for ESXI that sets the subformat to monlithicFlat, and the adapter_type to the SCSI lsilogic controller. This change existed back on: 25e36d379e73d64d6316fae9dc841c5ef28980f1 But it looks like the change was removed when refactoring occurred with: 5f6a2732f892b6229473576d89cc963ae9c97d5d Signed-off-by: John Sommerville <jsommerville@untangle.com>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 4383bcdcb2..eb0db417a3 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -133,6 +133,12 @@ ifneq ($(CONFIG_VMDK_IMAGES),)
$(STAGING_DIR_HOST)/bin/qemu-img convert -f raw -O vmdk \
$(BIN_DIR)/$(IMG_COMBINED)-$(1).img \
$(BIN_DIR)/$(IMG_COMBINED)-$(1).vmdk
+ #build the ESXI VMDK with
+ rm $(BIN_DIR)/$(IMG_COMBINED)-$(1)-esxi.vmdk || true
+ rm $(BIN_DIR)/$(IMG_COMBINED)-$(1)-esxi-flat.vmdk || true
+ $(STAGING_DIR_HOST)/bin/qemu-img convert -f raw -O vmdk -o adapter_type=lsilogic,subformat=monolithicFlat \
+ $(BIN_DIR)/$(IMG_COMBINED)-$(1).img \
+ $(BIN_DIR)/$(IMG_COMBINED)-$(1)-esxi.vmdk
endef
endif