aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-07-31 16:34:38 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-03 00:30:09 +0100
commit14d17306bc73a2ef512758c72af0f0f99aef7a2a (patch)
tree79d40c29d7be3a7036fccf8a8fc9b97099f07c01 /target/linux/x86
parent81f7af48811656dc12c720efda3f88e088d39b2b (diff)
downloadupstream-14d17306bc73a2ef512758c72af0f0f99aef7a2a.tar.gz
upstream-14d17306bc73a2ef512758c72af0f0f99aef7a2a.tar.bz2
upstream-14d17306bc73a2ef512758c72af0f0f99aef7a2a.zip
x86: make profile titles more verbose
So far (nearly) all x86 profiles are called "Generic" which makes it hard to distinguish them in special cases, like searching for a specific profile (without pre-selecting target/subtarget). To make this change locally working, remove the tmp/ folder to force reload of menuconfig. As these files are infrequently touched, the Copyright was updated as well. Signed-off-by: Paul Spooren <mail@aparcar.org> [changed commit title] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/64/Makefile0
-rw-r--r--target/linux/x86/64/profiles/000-Generic.mk6
-rw-r--r--target/linux/x86/generic/profiles/000-Generic.mk6
-rw-r--r--target/linux/x86/geode/profiles/000-Generic.mk4
-rw-r--r--target/linux/x86/geode/profiles/100-Geos.mk2
-rw-r--r--target/linux/x86/legacy/profiles/000-Generic.mk6
6 files changed, 12 insertions, 12 deletions
diff --git a/target/linux/x86/64/Makefile b/target/linux/x86/64/Makefile
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/target/linux/x86/64/Makefile
diff --git a/target/linux/x86/64/profiles/000-Generic.mk b/target/linux/x86/64/profiles/000-Generic.mk
index ccd125afa2..b5b10c4ade 100644
--- a/target/linux/x86/64/profiles/000-Generic.mk
+++ b/target/linux/x86/64/profiles/000-Generic.mk
@@ -1,15 +1,15 @@
#
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2019 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
define Profile/Generic
- NAME:=Generic
+ NAME:=Generic x86/64
endef
define Profile/Generic/Description
- Generic Profile
+ Generic Profile for x86/64 architecture
endef
$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/generic/profiles/000-Generic.mk b/target/linux/x86/generic/profiles/000-Generic.mk
index 4760767eee..7717131be0 100644
--- a/target/linux/x86/generic/profiles/000-Generic.mk
+++ b/target/linux/x86/generic/profiles/000-Generic.mk
@@ -1,12 +1,12 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2019 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
define Profile/Generic
- NAME:=Generic
+ NAME:=Generic x86
PACKAGES:=kmod-e1000e kmod-igb kmod-bnx2 \
kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
@@ -14,6 +14,6 @@ define Profile/Generic
endef
define Profile/Generic/Description
- Generic Profile
+ Generic Profile for x86 architecture
endef
$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/geode/profiles/000-Generic.mk b/target/linux/x86/geode/profiles/000-Generic.mk
index 58dc3c641c..be11b33e97 100644
--- a/target/linux/x86/geode/profiles/000-Generic.mk
+++ b/target/linux/x86/geode/profiles/000-Generic.mk
@@ -1,12 +1,12 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2019 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
define Profile/Generic
- NAME:=Generic
+ NAME:=Generic x86/Geode
PACKAGES:= \
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
diff --git a/target/linux/x86/geode/profiles/100-Geos.mk b/target/linux/x86/geode/profiles/100-Geos.mk
index 94e501edf4..f51e892cbf 100644
--- a/target/linux/x86/geode/profiles/100-Geos.mk
+++ b/target/linux/x86/geode/profiles/100-Geos.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2019 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
diff --git a/target/linux/x86/legacy/profiles/000-Generic.mk b/target/linux/x86/legacy/profiles/000-Generic.mk
index 90f989a91d..566a66c1be 100644
--- a/target/linux/x86/legacy/profiles/000-Generic.mk
+++ b/target/linux/x86/legacy/profiles/000-Generic.mk
@@ -1,18 +1,18 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2019 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
define Profile/Generic
- NAME:=Generic
+ NAME:=Generic x86/legacy
PACKAGES:=kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
kmod-via-rhine kmod-via-velocity
endef
define Profile/Generic/Description
- Generic Profile
+ Generic Profile for x86 legacy architecutre
endef
$(eval $(call Profile,Generic))