aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-03-28 15:05:25 +0000
committerPetr Štetiar <ynezz@true.cz>2019-06-25 14:12:22 +0000
commita17d9482f5e218da2c0bcaa41662f355ee32be07 (patch)
tree518afe0f1b6eb14ce8db72d9eb2c147a1cf3b5fd /target/linux/x86
parent438a2c5f4a58019ffe97de9fa353cb5417930d25 (diff)
downloadupstream-a17d9482f5e218da2c0bcaa41662f355ee32be07.tar.gz
upstream-a17d9482f5e218da2c0bcaa41662f355ee32be07.tar.bz2
upstream-a17d9482f5e218da2c0bcaa41662f355ee32be07.zip
x86: image: fix small disk space in squashfs overlay
Current squashfs snapshot images are improperly padded by just 128k, which doesn't correspond with TARGET_ROOTFS_PARTSIZE=128 default config option, leading to following: Filesystem Size Used Available Use% Mounted on /dev/root 2.5M 2.5M 0 100% /rom /dev/loop0 85.0K 9.0K 71.0K 11% /overlay overlayfs:/overlay 85.0K 9.0K 71.0K 11% / Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/image/Makefile13
1 files changed, 1 insertions, 12 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 0771547f29..24825f2ba2 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -93,10 +93,6 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
endef
endif
-define Image/Build/squashfs
- dd if=/dev/zero bs=128k count=1 >> $(KDIR)/root.squashfs
-endef
-
define Image/Build/iso
$(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
$(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
@@ -146,14 +142,7 @@ define Image/Build/gzip
gzip -f9n $(BIN_DIR)/$(IMG_ROOTFS)-$(1).img
endef
-ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
- define Image/Build/gzip/ext4
- $(call Image/Build/gzip,ext4)
- endef
- define Image/Build/gzip/squashfs
- $(call Image/Build/gzip,squashfs)
- endef
-endif
+$(eval $(call Image/gzip-ext4-padded-squashfs))
define Image/BuildKernel
$(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz