aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/thincan
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-16 07:05:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-16 07:05:30 +0000
commit9e0759ea2653475f4e891c412fa503e9a9b08478 (patch)
treead7553c4f7d9bd7658a745b9577449d57925801f /target/linux/x86/thincan
parentf60113762adbf2cf3aab2c57e2559c61ab98cb18 (diff)
downloadupstream-9e0759ea2653475f4e891c412fa503e9a9b08478.tar.gz
upstream-9e0759ea2653475f4e891c412fa503e9a9b08478.tar.bz2
upstream-9e0759ea2653475f4e891c412fa503e9a9b08478.zip
x86: merge all geode based subtargets into one
Build all geode platform drivers into the kernel Remove kmod-* packages for these drivers Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44809
Diffstat (limited to 'target/linux/x86/thincan')
-rw-r--r--target/linux/x86/thincan/base-files/etc/init.d/alsa9
-rw-r--r--target/linux/x86/thincan/config-default15
-rw-r--r--target/linux/x86/thincan/profiles/dbe61.mk25
-rw-r--r--target/linux/x86/thincan/target.mk35
4 files changed, 0 insertions, 84 deletions
diff --git a/target/linux/x86/thincan/base-files/etc/init.d/alsa b/target/linux/x86/thincan/base-files/etc/init.d/alsa
deleted file mode 100644
index 94c6965e7e..0000000000
--- a/target/linux/x86/thincan/base-files/etc/init.d/alsa
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-START=50
-
-start() {
- amixer set PCM 50% unmute
- amixer set Headphone 100% unmute
-}
-
diff --git a/target/linux/x86/thincan/config-default b/target/linux/x86/thincan/config-default
deleted file mode 100644
index 405c65b5fc..0000000000
--- a/target/linux/x86/thincan/config-default
+++ /dev/null
@@ -1,15 +0,0 @@
-CONFIG_8139TOO=y
-# CONFIG_8139TOO_8129 is not set
-# CONFIG_8139TOO_PIO is not set
-# CONFIG_8139TOO_TUNE_TWISTER is not set
-# CONFIG_8139_OLD_RX_RESET is not set
-CONFIG_BLK_DEV_NBD=y
-# CONFIG_EMBEDDED is not set
-CONFIG_IP_PNP=y
-# CONFIG_IP_PNP_BOOTP is not set
-CONFIG_IP_PNP_DHCP=y
-# CONFIG_IP_PNP_RARP is not set
-CONFIG_LOCKD=y
-CONFIG_NFS_FS=y
-CONFIG_ROOT_NFS=y
-CONFIG_SUNRPC=y
diff --git a/target/linux/x86/thincan/profiles/dbe61.mk b/target/linux/x86/thincan/profiles/dbe61.mk
deleted file mode 100644
index ee7c251a37..0000000000
--- a/target/linux/x86/thincan/profiles/dbe61.mk
+++ /dev/null
@@ -1,25 +0,0 @@
-#
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/DBE61
- NAME:=DBE61
-endef
-
-define Profile/DBE61/Description
- Compile OpenWrt for Artec ThinCan DBE61
-
- ThinCan DBE61 is a thin-client featuring:
- * AMD Geode LX700
- * AMD CS5535 companion device
- * 64MB or 256MB NAND Flash or none
- * 128MB or 256MB DDR SDRAM
- * Realtek RTL8139
-
- http://wiki.thincan.org/DBE61
-endef
-
-$(eval $(call Profile,DBE61))
diff --git a/target/linux/x86/thincan/target.mk b/target/linux/x86/thincan/target.mk
deleted file mode 100644
index 8081353957..0000000000
--- a/target/linux/x86/thincan/target.mk
+++ /dev/null
@@ -1,35 +0,0 @@
-DEVICE_TYPE:=terminal
-BOARDNAME:=Artec ThinCan
-CPU_TYPE := geode
-FEATURES += broken
-
-DEFAULT_PACKAGES:=\
- base-files \
- busybox \
- hotplug2 \
- libc \
- libgcc \
- opkg \
- uci \
- udevtrigger \
- kmod-fs-msdos \
- kmod-fs-vfat \
- kmod-fs-ext4 \
- kmod-usb-core \
- kmod-usb-ohci \
- kmod-usb-hid \
- kmod-usb-storage \
- kmod-usb2-pci \
- kmod-sound-core \
- kmod-sound-cs5535audio \
- kmod-crypto-core \
- kmod-crypto-hw-geode \
- kmod-crypto-ocf \
- kmod-crypto-aes
-
-define Target/Description
- Build firmware images for Artec ThinCan
-
- Note that NBD, NFS, DHCP and ethernet module are built into kernel
-endef
-