aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/patches-5.10
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2021-03-08 19:16:11 -0800
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2021-03-14 17:52:49 +0000
commit839178138957dd891f37b8945cceb3875d043b10 (patch)
tree6d70ba9e3aac2ef62d3290d6f78c197714fe23bb /target/linux/x86/patches-5.10
parent95a3741d17b4cd7b9441187c356d449d0aa9d75d (diff)
downloadupstream-839178138957dd891f37b8945cceb3875d043b10.tar.gz
upstream-839178138957dd891f37b8945cceb3875d043b10.tar.bz2
upstream-839178138957dd891f37b8945cceb3875d043b10.zip
x86: support kernel 5.10
Add linux 5.10 as testing kernel, copy generic/subtarget configs and target patches from 5.4. Signed-off-by: Tony Ambardar <itugrok@yahoo.com> x86: update target patches for kernel 5.10 Refresh all patches while also dropping: 800-hwmon-w83627ehf-dont-claim-nct677x.patch which is now upstreamed as: 3207408ab4cb ("hwmon: (w83627ehf) remove nct6775 and nct6776 support") Signed-off-by: Tony Ambardar <itugrok@yahoo.com> x86: refresh 5.10 target config Refresh config using "make kernel_oldconfig". Signed-off-by: Tony Ambardar <itugrok@yahoo.com> x86: refresh and test all subtarget configs Refresh configs using "make kernel_oldconfig CONFIG_TARGET=subtarget". Build and run-tested using QEMU: x86/64, x86/legacy, x86/generic. Build-tested only: x86/geode. Signed-off-by: Tony Ambardar <itugrok@yahoo.com> [squashed commits] Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'target/linux/x86/patches-5.10')
-rw-r--r--target/linux/x86/patches-5.10/011-tune_lzma_options.patch22
-rw-r--r--target/linux/x86/patches-5.10/012-pcengines-apu2-detect-apuv4-board.patch50
-rw-r--r--target/linux/x86/patches-5.10/100-fix_cs5535_clockevt.patch13
-rw-r--r--target/linux/x86/patches-5.10/200-pcengines-apu2-reboot.patch19
-rw-r--r--target/linux/x86/patches-5.10/300-pcengines_apu1_led.patch41
5 files changed, 145 insertions, 0 deletions
diff --git a/target/linux/x86/patches-5.10/011-tune_lzma_options.patch b/target/linux/x86/patches-5.10/011-tune_lzma_options.patch
new file mode 100644
index 0000000000..c19e1f54db
--- /dev/null
+++ b/target/linux/x86/patches-5.10/011-tune_lzma_options.patch
@@ -0,0 +1,22 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -370,7 +370,7 @@ quiet_cmd_bzip2 = BZIP2 $@
+ # ---------------------------------------------------------------------------
+
+ quiet_cmd_lzma = LZMA $@
+- cmd_lzma = { cat $(real-prereqs) | $(LZMA) e -d20 -lc1 -lp2 -pb2 -eos -si -so; $(size_append); } > $@
++ cmd_lzma = { cat $(real-prereqs) | $(LZMA) e -lc8 -eos -si -so; $(size_append); } > $@
+
+ quiet_cmd_lzo = LZO $@
+ cmd_lzo = { cat $(real-prereqs) | $(KLZOP) -9; $(size_append); } > $@
+--- a/arch/x86/include/asm/boot.h
++++ b/arch/x86/include/asm/boot.h
+@@ -24,7 +24,7 @@
+ # error "Invalid value for CONFIG_PHYSICAL_ALIGN"
+ #endif
+
+-#if defined(CONFIG_KERNEL_BZIP2)
++#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
+ # define BOOT_HEAP_SIZE 0x400000
+ #elif defined(CONFIG_KERNEL_ZSTD)
+ /*
diff --git a/target/linux/x86/patches-5.10/012-pcengines-apu2-detect-apuv4-board.patch b/target/linux/x86/patches-5.10/012-pcengines-apu2-detect-apuv4-board.patch
new file mode 100644
index 0000000000..989b91a691
--- /dev/null
+++ b/target/linux/x86/patches-5.10/012-pcengines-apu2-detect-apuv4-board.patch
@@ -0,0 +1,50 @@
+From 3d00da1de3ea36ba44f4a7ba76c8c8b16f98204b Mon Sep 17 00:00:00 2001
+From: "Enrico Weigelt, metux IT consult" <info@metux.net>
+Date: Thu, 12 Dec 2019 14:27:56 +0100
+Subject: [PATCH] platform/x86: pcengines-apuv2: detect apuv4 board
+
+GPIO stuff on APUv4 seems to be the same as on APUv2, so we just
+need to match on DMI data.
+
+Signed-off-by: Enrico Weigelt, metux IT consult <info@metux.net>
+Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
+---
+ drivers/platform/x86/pcengines-apuv2.c | 27 ++++++++++++++++++++++++++
+ 1 file changed, 27 insertions(+)
+
+--- a/drivers/platform/x86/pcengines-apuv2.c
++++ b/drivers/platform/x86/pcengines-apuv2.c
+@@ -213,6 +213,33 @@ static const struct dmi_system_id apu_gp
+ },
+ .driver_data = (void *)&board_apu2,
+ },
++ /* APU4 w/ legacy bios < 4.0.8 */
++ {
++ .ident = "apu4",
++ .matches = {
++ DMI_MATCH(DMI_SYS_VENDOR, "PC Engines"),
++ DMI_MATCH(DMI_BOARD_NAME, "APU4")
++ },
++ .driver_data = (void *)&board_apu2,
++ },
++ /* APU4 w/ legacy bios >= 4.0.8 */
++ {
++ .ident = "apu4",
++ .matches = {
++ DMI_MATCH(DMI_SYS_VENDOR, "PC Engines"),
++ DMI_MATCH(DMI_BOARD_NAME, "apu4")
++ },
++ .driver_data = (void *)&board_apu2,
++ },
++ /* APU4 w/ mainline bios */
++ {
++ .ident = "apu4",
++ .matches = {
++ DMI_MATCH(DMI_SYS_VENDOR, "PC Engines"),
++ DMI_MATCH(DMI_BOARD_NAME, "PC Engines apu4")
++ },
++ .driver_data = (void *)&board_apu2,
++ },
+ {}
+ };
+
diff --git a/target/linux/x86/patches-5.10/100-fix_cs5535_clockevt.patch b/target/linux/x86/patches-5.10/100-fix_cs5535_clockevt.patch
new file mode 100644
index 0000000000..d4de2027ba
--- /dev/null
+++ b/target/linux/x86/patches-5.10/100-fix_cs5535_clockevt.patch
@@ -0,0 +1,13 @@
+--- a/drivers/clocksource/timer-cs5535.c
++++ b/drivers/clocksource/timer-cs5535.c
+@@ -127,7 +127,9 @@ static irqreturn_t mfgpt_tick(int irq, v
+ cs5535_mfgpt_write(cs5535_event_clock, MFGPT_REG_SETUP,
+ MFGPT_SETUP_CNTEN | MFGPT_SETUP_CMP2);
+
+- cs5535_clockevent.event_handler(&cs5535_clockevent);
++ if (cs5535_clockevent.event_handler)
++ cs5535_clockevent.event_handler(&cs5535_clockevent);
++
+ return IRQ_HANDLED;
+ }
+
diff --git a/target/linux/x86/patches-5.10/200-pcengines-apu2-reboot.patch b/target/linux/x86/patches-5.10/200-pcengines-apu2-reboot.patch
new file mode 100644
index 0000000000..bc57806c74
--- /dev/null
+++ b/target/linux/x86/patches-5.10/200-pcengines-apu2-reboot.patch
@@ -0,0 +1,19 @@
+--- a/arch/x86/kernel/reboot.c
++++ b/arch/x86/kernel/reboot.c
+@@ -477,6 +477,16 @@ static const struct dmi_system_id reboot
+ },
+ },
+
++ /* PC Engines */
++ { /* Handle problems with rebooting on PC Engines apu2 */
++ .callback = set_pci_reboot,
++ .ident = "PC Engines apu2",
++ .matches = {
++ DMI_MATCH(DMI_BOARD_VENDOR, "PC Engines"),
++ DMI_MATCH(DMI_BOARD_NAME, "apu2"),
++ },
++ },
++
+ /* Sony */
+ { /* Handle problems with rebooting on Sony VGN-Z540N */
+ .callback = set_bios_reboot,
diff --git a/target/linux/x86/patches-5.10/300-pcengines_apu1_led.patch b/target/linux/x86/patches-5.10/300-pcengines_apu1_led.patch
new file mode 100644
index 0000000000..9d1e4ab9c2
--- /dev/null
+++ b/target/linux/x86/patches-5.10/300-pcengines_apu1_led.patch
@@ -0,0 +1,41 @@
+From: Andreas Eberlein <foodeas@aeberlein.de>
+Subject: x86: add LED support for PC Engines APU1 with mainline bios
+
+This adds support for the LEDs on PC Engines APU1 with the mainline bios.
+
+Signed-off-by: Andreas Eberlein <foodeas@aeberlein.de>
+---
+--- a/drivers/leds/leds-apu.c
++++ b/drivers/leds/leds-apu.c
+@@ -83,6 +83,7 @@ static const struct apu_led_profile apu1
+ };
+
+ static const struct dmi_system_id apu_led_dmi_table[] __initconst = {
++ /* PC Engines APU with "Legacy" bios < 4.0.8 */
+ {
+ .ident = "apu",
+ .matches = {
+@@ -90,6 +91,14 @@ static const struct dmi_system_id apu_le
+ DMI_MATCH(DMI_PRODUCT_NAME, "APU")
+ }
+ },
++ /* PC Engines APU with "Mainline" bios >= 4.0.8 */
++ {
++ .ident = "apu",
++ .matches = {
++ DMI_MATCH(DMI_SYS_VENDOR, "PC Engines"),
++ DMI_MATCH(DMI_PRODUCT_NAME, "apu1")
++ }
++ },
+ {}
+ };
+ MODULE_DEVICE_TABLE(dmi, apu_led_dmi_table);
+@@ -173,7 +182,7 @@ static int __init apu_led_init(void)
+ int err;
+
+ if (!(dmi_match(DMI_SYS_VENDOR, "PC Engines") &&
+- dmi_match(DMI_PRODUCT_NAME, "APU"))) {
++ (dmi_match(DMI_PRODUCT_NAME, "APU") || dmi_match(DMI_PRODUCT_NAME, "apu1")))) {
+ pr_err("No PC Engines APUv1 board detected. For APUv2,3 support, enable CONFIG_PCENGINES_APU2\n");
+ return -ENODEV;
+ }