aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/patches-4.4
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-01 11:23:43 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-07 17:30:39 +0100
commit83ab1982b457cf967e3d349f55518b4a7072ae5d (patch)
treef20bf95a6badf800cd8f8f7e6ab66b1df9ef5be7 /target/linux/x86/patches-4.4
parent92bda4ae5c6aac89e612c338bf9e9e6e9ee96aca (diff)
downloadupstream-83ab1982b457cf967e3d349f55518b4a7072ae5d.tar.gz
upstream-83ab1982b457cf967e3d349f55518b4a7072ae5d.tar.bz2
upstream-83ab1982b457cf967e3d349f55518b4a7072ae5d.zip
x86: remove linux 4.4 support
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/x86/patches-4.4')
-rw-r--r--target/linux/x86/patches-4.4/011-tune_lzma_options.patch22
-rw-r--r--target/linux/x86/patches-4.4/097-0001-sp5100_tco-Add-AMD-Mullins-platform-support.patch26
-rw-r--r--target/linux/x86/patches-4.4/097-0002-sp5100_tco-Add-AMD-Carrizo-platform-support.patch27
-rw-r--r--target/linux/x86/patches-4.4/097-0003-sp5100_tco-fix-the-device-check-for-SB800-and-later-chipsets.patch76
-rw-r--r--target/linux/x86/patches-4.4/097-0004-watchdog-sp5100_tco-properly-check-for-new-register-.patch72
-rw-r--r--target/linux/x86/patches-4.4/100-fix_cs5535_clockevt.patch12
6 files changed, 0 insertions, 235 deletions
diff --git a/target/linux/x86/patches-4.4/011-tune_lzma_options.patch b/target/linux/x86/patches-4.4/011-tune_lzma_options.patch
deleted file mode 100644
index 5f8f5d8218..0000000000
--- a/target/linux/x86/patches-4.4/011-tune_lzma_options.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/scripts/Makefile.lib
-+++ b/scripts/Makefile.lib
-@@ -324,7 +324,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
-
- quiet_cmd_lzma = LZMA $@
- cmd_lzma = (cat $(filter-out FORCE,$^) | \
-- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
-+ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
- (rm -f $@ ; false)
-
- quiet_cmd_lzo = LZO $@
---- a/arch/x86/include/asm/boot.h
-+++ b/arch/x86/include/asm/boot.h
-@@ -23,7 +23,7 @@
- #error "Invalid value for CONFIG_PHYSICAL_ALIGN"
- #endif
-
--#ifdef CONFIG_KERNEL_BZIP2
-+#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
- #define BOOT_HEAP_SIZE 0x400000
- #else /* !CONFIG_KERNEL_BZIP2 */
-
diff --git a/target/linux/x86/patches-4.4/097-0001-sp5100_tco-Add-AMD-Mullins-platform-support.patch b/target/linux/x86/patches-4.4/097-0001-sp5100_tco-Add-AMD-Mullins-platform-support.patch
deleted file mode 100644
index 70169abbe4..0000000000
--- a/target/linux/x86/patches-4.4/097-0001-sp5100_tco-Add-AMD-Mullins-platform-support.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 190aa4304de6fe2185d96392ddf56580fa133e99 Mon Sep 17 00:00:00 2001
-From: Denis Turischev <denis.turischev@compulab.co.il>
-Date: Tue, 24 Nov 2015 10:46:12 +0200
-Subject: [PATCH] sp5100_tco: Add AMD Mullins platform support
-
-AMD Mullins watchdog is fully compatible to the previous Hudson chipset,
-reuse the existent sp5100_tco driver.
-
-Signed-off-by: Denis Turischev <denis.turischev@compulab.co.il>
-Signed-off-by: Guenter Roeck <linux@roeck-us.net>
-Signed-off-by: Wim Van Sebroeck <wim@iguana.be>
----
- drivers/watchdog/sp5100_tco.c | 2 ++
- 1 file changed, 2 insertions(+)
-
---- a/drivers/watchdog/sp5100_tco.c
-+++ b/drivers/watchdog/sp5100_tco.c
-@@ -306,6 +306,8 @@ static struct miscdevice sp5100_tco_misc
- static const struct pci_device_id sp5100_tco_pci_tbl[] = {
- { PCI_VENDOR_ID_ATI, PCI_DEVICE_ID_ATI_SBX00_SMBUS, PCI_ANY_ID,
- PCI_ANY_ID, },
-+ { PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_HUDSON2_SMBUS, PCI_ANY_ID,
-+ PCI_ANY_ID, },
- { 0, }, /* End of list */
- };
- MODULE_DEVICE_TABLE(pci, sp5100_tco_pci_tbl);
diff --git a/target/linux/x86/patches-4.4/097-0002-sp5100_tco-Add-AMD-Carrizo-platform-support.patch b/target/linux/x86/patches-4.4/097-0002-sp5100_tco-Add-AMD-Carrizo-platform-support.patch
deleted file mode 100644
index 33862a25d0..0000000000
--- a/target/linux/x86/patches-4.4/097-0002-sp5100_tco-Add-AMD-Carrizo-platform-support.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From cca118fa2a0a94e0f0b3c8dd1dda922cdee45089 Mon Sep 17 00:00:00 2001
-From: Huang Rui <ray.huang@amd.com>
-Date: Mon, 23 Nov 2015 18:07:36 +0800
-Subject: [PATCH] sp5100_tco: Add AMD Carrizo platform support
-
-sp5100_tco watchdog is also supported on AMD KernCZ chipset of Carrizo
-platform.
-
-Signed-off-by: Huang Rui <ray.huang@amd.com>
-Cc: Denis Turischev <denis.turischev@compulab.co.il>
-Signed-off-by: Guenter Roeck <linux@roeck-us.net>
-Signed-off-by: Wim Van Sebroeck <wim@iguana.be>
----
- drivers/watchdog/sp5100_tco.c | 2 ++
- 1 file changed, 2 insertions(+)
-
---- a/drivers/watchdog/sp5100_tco.c
-+++ b/drivers/watchdog/sp5100_tco.c
-@@ -308,6 +308,8 @@ static const struct pci_device_id sp5100
- PCI_ANY_ID, },
- { PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_HUDSON2_SMBUS, PCI_ANY_ID,
- PCI_ANY_ID, },
-+ { PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_KERNCZ_SMBUS, PCI_ANY_ID,
-+ PCI_ANY_ID, },
- { 0, }, /* End of list */
- };
- MODULE_DEVICE_TABLE(pci, sp5100_tco_pci_tbl);
diff --git a/target/linux/x86/patches-4.4/097-0003-sp5100_tco-fix-the-device-check-for-SB800-and-later-chipsets.patch b/target/linux/x86/patches-4.4/097-0003-sp5100_tco-fix-the-device-check-for-SB800-and-later-chipsets.patch
deleted file mode 100644
index 8f16fa9906..0000000000
--- a/target/linux/x86/patches-4.4/097-0003-sp5100_tco-fix-the-device-check-for-SB800-and-later-chipsets.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From bdecfcdb5461834aab24002bb18d3cbdd907b7fb Mon Sep 17 00:00:00 2001
-From: Huang Rui <ray.huang@amd.com>
-Date: Mon, 23 Nov 2015 18:07:35 +0800
-Subject: [PATCH] sp5100_tco: fix the device check for SB800 and later chipsets
-
-For SB800 and later chipsets, the register definitions are the same
-with SB800. And for SB700 and older chipsets, the definitions should
-be same with SP5100/SB7x0.
-
-Signed-off-by: Huang Rui <ray.huang@amd.com>
-Cc: Denis Turischev <denis.turischev@compulab.co.il>
-Signed-off-by: Guenter Roeck <linux@roeck-us.net>
-Signed-off-by: Wim Van Sebroeck <wim@iguana.be>
----
- drivers/watchdog/sp5100_tco.c | 28 ++++++++++++++++------------
- 1 file changed, 16 insertions(+), 12 deletions(-)
-
---- a/drivers/watchdog/sp5100_tco.c
-+++ b/drivers/watchdog/sp5100_tco.c
-@@ -335,21 +335,24 @@ static unsigned char sp5100_tco_setupdev
- if (!sp5100_tco_pci)
- return 0;
-
-- pr_info("PCI Revision ID: 0x%x\n", sp5100_tco_pci->revision);
-+ pr_info("PCI Vendor ID: 0x%x, Device ID: 0x%x, Revision ID: 0x%x\n",
-+ sp5100_tco_pci->vendor, sp5100_tco_pci->device,
-+ sp5100_tco_pci->revision);
-
- /*
- * Determine type of southbridge chipset.
- */
-- if (sp5100_tco_pci->revision >= 0x40) {
-- dev_name = SB800_DEVNAME;
-- index_reg = SB800_IO_PM_INDEX_REG;
-- data_reg = SB800_IO_PM_DATA_REG;
-- base_addr = SB800_PM_WATCHDOG_BASE;
-- } else {
-+ if (sp5100_tco_pci->device == PCI_DEVICE_ID_ATI_SBX00_SMBUS &&
-+ sp5100_tco_pci->revision < 0x40) {
- dev_name = SP5100_DEVNAME;
- index_reg = SP5100_IO_PM_INDEX_REG;
- data_reg = SP5100_IO_PM_DATA_REG;
- base_addr = SP5100_PM_WATCHDOG_BASE;
-+ } else {
-+ dev_name = SB800_DEVNAME;
-+ index_reg = SB800_IO_PM_INDEX_REG;
-+ data_reg = SB800_IO_PM_DATA_REG;
-+ base_addr = SB800_PM_WATCHDOG_BASE;
- }
-
- /* Request the IO ports used by this driver */
-@@ -385,7 +388,12 @@ static unsigned char sp5100_tco_setupdev
- * Secondly, Find the watchdog timer MMIO address
- * from SBResource_MMIO register.
- */
-- if (sp5100_tco_pci->revision >= 0x40) {
-+ if (sp5100_tco_pci->device == PCI_DEVICE_ID_ATI_SBX00_SMBUS &&
-+ sp5100_tco_pci->revision < 0x40) {
-+ /* Read SBResource_MMIO from PCI config(PCI_Reg: 9Ch) */
-+ pci_read_config_dword(sp5100_tco_pci,
-+ SP5100_SB_RESOURCE_MMIO_BASE, &val);
-+ } else {
- /* Read SBResource_MMIO from AcpiMmioEn(PM_Reg: 24h) */
- outb(SB800_PM_ACPI_MMIO_EN+3, SB800_IO_PM_INDEX_REG);
- val = inb(SB800_IO_PM_DATA_REG);
-@@ -395,10 +403,6 @@ static unsigned char sp5100_tco_setupdev
- val = val << 8 | inb(SB800_IO_PM_DATA_REG);
- outb(SB800_PM_ACPI_MMIO_EN+0, SB800_IO_PM_INDEX_REG);
- val = val << 8 | inb(SB800_IO_PM_DATA_REG);
-- } else {
-- /* Read SBResource_MMIO from PCI config(PCI_Reg: 9Ch) */
-- pci_read_config_dword(sp5100_tco_pci,
-- SP5100_SB_RESOURCE_MMIO_BASE, &val);
- }
-
- /* The SBResource_MMIO is enabled and mapped memory space? */
diff --git a/target/linux/x86/patches-4.4/097-0004-watchdog-sp5100_tco-properly-check-for-new-register-.patch b/target/linux/x86/patches-4.4/097-0004-watchdog-sp5100_tco-properly-check-for-new-register-.patch
deleted file mode 100644
index 103aa4853d..0000000000
--- a/target/linux/x86/patches-4.4/097-0004-watchdog-sp5100_tco-properly-check-for-new-register-.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From 46856fabe40cc80f92134683cdec7dc0fc8f4000 Mon Sep 17 00:00:00 2001
-From: Lucas Stach <dev@lynxeye.de>
-Date: Tue, 3 May 2016 19:15:58 +0200
-Subject: [PATCH] watchdog: sp5100_tco: properly check for new register layouts
-
-Commits 190aa4304de6 (Add AMD Mullins platform support) and
-cca118fa2a0a94 (Add AMD Carrizo platform support) enabled the
-driver on a lot more devices, but the following commit missed
-a single location in the code when checking if the SB800 register
-offsets should be used. This leads to the wrong register being
-written which in turn causes ACPI to go haywire.
-
-Fix this by introducing a helper function to check for the new
-register layout and use this consistently.
-
-https://bugzilla.kernel.org/show_bug.cgi?id=114201
-https://bugzilla.redhat.com/show_bug.cgi?id=1329910
-Fixes: bdecfcdb5461 (sp5100_tco: fix the device check for SB800
-and later chipsets)
-Cc: stable@vger.kernel.org (4.5+)
-Signed-off-by: Lucas Stach <dev@lynxeye.de>
-Signed-off-by: Guenter Roeck <linux@roeck-us.net>
-Signed-off-by: Wim Van Sebroeck <wim@iguana.be>
----
- drivers/watchdog/sp5100_tco.c | 15 ++++++++++-----
- 1 file changed, 10 insertions(+), 5 deletions(-)
-
---- a/drivers/watchdog/sp5100_tco.c
-+++ b/drivers/watchdog/sp5100_tco.c
-@@ -73,6 +73,13 @@ MODULE_PARM_DESC(nowayout, "Watchdog can
- /*
- * Some TCO specific functions
- */
-+
-+static bool tco_has_sp5100_reg_layout(struct pci_dev *dev)
-+{
-+ return dev->device == PCI_DEVICE_ID_ATI_SBX00_SMBUS &&
-+ dev->revision < 0x40;
-+}
-+
- static void tco_timer_start(void)
- {
- u32 val;
-@@ -129,7 +136,7 @@ static void tco_timer_enable(void)
- {
- int val;
-
-- if (sp5100_tco_pci->revision >= 0x40) {
-+ if (!tco_has_sp5100_reg_layout(sp5100_tco_pci)) {
- /* For SB800 or later */
- /* Set the Watchdog timer resolution to 1 sec */
- outb(SB800_PM_WATCHDOG_CONFIG, SB800_IO_PM_INDEX_REG);
-@@ -342,8 +349,7 @@ static unsigned char sp5100_tco_setupdev
- /*
- * Determine type of southbridge chipset.
- */
-- if (sp5100_tco_pci->device == PCI_DEVICE_ID_ATI_SBX00_SMBUS &&
-- sp5100_tco_pci->revision < 0x40) {
-+ if (tco_has_sp5100_reg_layout(sp5100_tco_pci)) {
- dev_name = SP5100_DEVNAME;
- index_reg = SP5100_IO_PM_INDEX_REG;
- data_reg = SP5100_IO_PM_DATA_REG;
-@@ -388,8 +394,7 @@ static unsigned char sp5100_tco_setupdev
- * Secondly, Find the watchdog timer MMIO address
- * from SBResource_MMIO register.
- */
-- if (sp5100_tco_pci->device == PCI_DEVICE_ID_ATI_SBX00_SMBUS &&
-- sp5100_tco_pci->revision < 0x40) {
-+ if (tco_has_sp5100_reg_layout(sp5100_tco_pci)) {
- /* Read SBResource_MMIO from PCI config(PCI_Reg: 9Ch) */
- pci_read_config_dword(sp5100_tco_pci,
- SP5100_SB_RESOURCE_MMIO_BASE, &val);
diff --git a/target/linux/x86/patches-4.4/100-fix_cs5535_clockevt.patch b/target/linux/x86/patches-4.4/100-fix_cs5535_clockevt.patch
deleted file mode 100644
index c49ddca7d6..0000000000
--- a/target/linux/x86/patches-4.4/100-fix_cs5535_clockevt.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/drivers/clocksource/cs5535-clockevt.c
-+++ b/drivers/clocksource/cs5535-clockevt.c
-@@ -129,7 +129,8 @@ static irqreturn_t mfgpt_tick(int irq, v
- cs5535_mfgpt_write(cs5535_event_clock, MFGPT_REG_SETUP,
- MFGPT_SETUP_CNTEN | MFGPT_SETUP_CMP2);
-
-- cs5535_clockevent.event_handler(&cs5535_clockevent);
-+ if (cs5535_clockevent.event_handler)
-+ cs5535_clockevent.event_handler(&cs5535_clockevent);
- return IRQ_HANDLED;
- }
-