aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/patches-4.14/011-tune_lzma_options.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-10-29 19:34:13 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-12-16 22:16:07 +0100
commit481e1f23f5a178f44f6cf89e761ab51d1fc8d6ed (patch)
tree80fef94230617a7513db7dcdb3259c3b0a3333b4 /target/linux/x86/patches-4.14/011-tune_lzma_options.patch
parent5c944d95ecc3c0f0e1d0f33d18574c1b7d29f6dd (diff)
downloadupstream-481e1f23f5a178f44f6cf89e761ab51d1fc8d6ed.tar.gz
upstream-481e1f23f5a178f44f6cf89e761ab51d1fc8d6ed.tar.bz2
upstream-481e1f23f5a178f44f6cf89e761ab51d1fc8d6ed.zip
x86: Add support for kernel 4.14
This adds basic support for kernel 4.14, this was tested in qemu only. The subtarget configuration was refresh with kernel 4.14 and the options needed to make it compile on kernel 4.9 were added manually. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/x86/patches-4.14/011-tune_lzma_options.patch')
-rw-r--r--target/linux/x86/patches-4.14/011-tune_lzma_options.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/x86/patches-4.14/011-tune_lzma_options.patch b/target/linux/x86/patches-4.14/011-tune_lzma_options.patch
new file mode 100644
index 0000000000..daed310a13
--- /dev/null
+++ b/target/linux/x86/patches-4.14/011-tune_lzma_options.patch
@@ -0,0 +1,22 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -348,7 +348,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+
+ quiet_cmd_lzma = LZMA $@
+ cmd_lzma = (cat $(filter-out FORCE,$^) | \
+- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
++ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ (rm -f $@ ; false)
+
+ quiet_cmd_lzo = LZO $@
+--- a/arch/x86/include/asm/boot.h
++++ b/arch/x86/include/asm/boot.h
+@@ -24,7 +24,7 @@
+ # error "Invalid value for CONFIG_PHYSICAL_ALIGN"
+ #endif
+
+-#ifdef CONFIG_KERNEL_BZIP2
++#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
+ # define BOOT_HEAP_SIZE 0x400000
+ #else /* !CONFIG_KERNEL_BZIP2 */
+ # define BOOT_HEAP_SIZE 0x10000