aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/patches-3.18/011-tune_lzma_options.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-15 04:43:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-15 04:43:30 +0000
commite08e457d55211a0711a07a4c3d6f1826813d3cc6 (patch)
tree65b9d91f2210c6d3a821dc600c2155bf1c5493d4 /target/linux/x86/patches-3.18/011-tune_lzma_options.patch
parenta4b632413a3365ac7347ca54dff7271e77fd8de2 (diff)
downloadupstream-e08e457d55211a0711a07a4c3d6f1826813d3cc6.tar.gz
upstream-e08e457d55211a0711a07a4c3d6f1826813d3cc6.tar.bz2
upstream-e08e457d55211a0711a07a4c3d6f1826813d3cc6.zip
x86: update to kernel 3.18
copied target/linux/x86/config-3.14 and target/linux/x86/patches-3.14 to 3.18 equivalents and then tweaked until it built. Tested on alix2, soekris net4826 and soekris net4521. Still having trouble with net4826 booting from Grub, alix2 and net4521 are fine. Signed-off-by: Russell Senior <russell@personaltelco.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44758 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/patches-3.18/011-tune_lzma_options.patch')
-rw-r--r--target/linux/x86/patches-3.18/011-tune_lzma_options.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/x86/patches-3.18/011-tune_lzma_options.patch b/target/linux/x86/patches-3.18/011-tune_lzma_options.patch
new file mode 100644
index 0000000000..168c3dd731
--- /dev/null
+++ b/target/linux/x86/patches-3.18/011-tune_lzma_options.patch
@@ -0,0 +1,22 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -304,7 +304,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+
+ quiet_cmd_lzma = LZMA $@
+ cmd_lzma = (cat $(filter-out FORCE,$^) | \
+- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
++ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ (rm -f $@ ; false)
+
+ quiet_cmd_lzo = LZO $@
+--- a/arch/x86/include/asm/boot.h
++++ b/arch/x86/include/asm/boot.h
+@@ -23,7 +23,7 @@
+ #error "Invalid value for CONFIG_PHYSICAL_ALIGN"
+ #endif
+
+-#ifdef CONFIG_KERNEL_BZIP2
++#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
+ #define BOOT_HEAP_SIZE 0x400000
+ #else /* !CONFIG_KERNEL_BZIP2 */
+