aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/patches-3.14/011-tune_lzma_options.patch
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-11-28 17:53:50 +0000
committerLuka Perkov <luka@openwrt.org>2014-11-28 17:53:50 +0000
commit64d9feeabf6c731cb700018dfef85a242848becf (patch)
tree50a10ce67b388e7652d9bc349ffc905736d1449b /target/linux/x86/patches-3.14/011-tune_lzma_options.patch
parent753167106850ac0cf651484208a4fc7fbf2e1bd1 (diff)
downloadupstream-64d9feeabf6c731cb700018dfef85a242848becf.tar.gz
upstream-64d9feeabf6c731cb700018dfef85a242848becf.tar.bz2
upstream-64d9feeabf6c731cb700018dfef85a242848becf.zip
x86: add support for 3.14
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43422 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/patches-3.14/011-tune_lzma_options.patch')
-rw-r--r--target/linux/x86/patches-3.14/011-tune_lzma_options.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/x86/patches-3.14/011-tune_lzma_options.patch b/target/linux/x86/patches-3.14/011-tune_lzma_options.patch
new file mode 100644
index 0000000000..168c3dd731
--- /dev/null
+++ b/target/linux/x86/patches-3.14/011-tune_lzma_options.patch
@@ -0,0 +1,22 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -304,7 +304,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+
+ quiet_cmd_lzma = LZMA $@
+ cmd_lzma = (cat $(filter-out FORCE,$^) | \
+- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
++ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ (rm -f $@ ; false)
+
+ quiet_cmd_lzo = LZO $@
+--- a/arch/x86/include/asm/boot.h
++++ b/arch/x86/include/asm/boot.h
+@@ -23,7 +23,7 @@
+ #error "Invalid value for CONFIG_PHYSICAL_ALIGN"
+ #endif
+
+-#ifdef CONFIG_KERNEL_BZIP2
++#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
+ #define BOOT_HEAP_SIZE 0x400000
+ #else /* !CONFIG_KERNEL_BZIP2 */
+