aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/modules.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-03-27 15:04:29 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-03-27 15:39:27 +0200
commiteeb8fd4ce7e90ec24287c469628ae528a14daa6f (patch)
treee899bd2192458742facee4467abbd7895bb946ee /target/linux/x86/modules.mk
parent73683454507163703beb3bc7d9f2e1dea189aa91 (diff)
downloadupstream-eeb8fd4ce7e90ec24287c469628ae528a14daa6f.tar.gz
upstream-eeb8fd4ce7e90ec24287c469628ae528a14daa6f.tar.bz2
upstream-eeb8fd4ce7e90ec24287c469628ae528a14daa6f.zip
gpio-cdev: move kmod-leds-uleds dependency to MX100
The inclusion of the kmod-leds-uleds into the userspace nu801 package causes a circular dependency inside the buildsystem... which causes it to be picked regardless of other DEPENDS values. In case of the mx100, this could be solved by moving the kmod-leds-uled dependency to the kmod-meraki-mx100. Bonus: drop @!LINUX_5_4 from kmod-meraki-mx100 Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/x86/modules.mk')
-rw-r--r--target/linux/x86/modules.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index 0071ebda41..f3226e3a60 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -87,8 +87,8 @@ $(eval $(call KernelPackage,pcengines-apuv2))
define KernelPackage/meraki-mx100
SUBMENU:=$(OTHER_MENU)
TITLE:=Cisco Meraki MX100 Platform Driver
- DEPENDS:=@TARGET_x86 @!LINUX_5_4 +kmod-tg3 +kmod-gpio-button-hotplug +kmod-leds-gpio \
- +kmod-usb-ledtrig-usbport +nu801 +kmod-itco-wdt
+ DEPENDS:=@TARGET_x86 +kmod-tg3 +kmod-gpio-button-hotplug +kmod-leds-gpio \
+ +kmod-usb-ledtrig-usbport +nu801 +kmod-itco-wdt +kmod-leds-uleds
KCONFIG:=CONFIG_MERAKI_MX100
FILES:=$(LINUX_DIR)/drivers/platform/x86/meraki-mx100.ko
AUTOLOAD:=$(call AutoLoad,60,meraki-mx100,1)