aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/modules.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2021-10-10 22:06:51 +0200
committerChristian Lamparter <chunkeey@gmail.com>2021-10-10 23:15:05 +0200
commit80b7a8a7f5a0a88fde6dd19f097df4d7cac9ff04 (patch)
treeddaa237a59884b598c6fc4ec72d50028bd0be8a5 /target/linux/x86/modules.mk
parent7c0fb874436c0613a042c8b07aa00621d08f4eaa (diff)
downloadupstream-80b7a8a7f5a0a88fde6dd19f097df4d7cac9ff04.tar.gz
upstream-80b7a8a7f5a0a88fde6dd19f097df4d7cac9ff04.tar.bz2
upstream-80b7a8a7f5a0a88fde6dd19f097df4d7cac9ff04.zip
Revert "gpio-cdev: add nu801 userspace driver"
This reverts commit f536f5ebddd9c532a08ac4a9be3ef0c02f7bfeb8. As Hauke commented, this causes builder failures on 5.4 kernels. This revert includes changes to the mx100 kernel modules dependency as well as the uci led definitions. Tested-by: Chris Blake <chrisrblake93@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/x86/modules.mk')
-rw-r--r--target/linux/x86/modules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index 0071ebda41..4005ee97ef 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -88,7 +88,7 @@ define KernelPackage/meraki-mx100
SUBMENU:=$(OTHER_MENU)
TITLE:=Cisco Meraki MX100 Platform Driver
DEPENDS:=@TARGET_x86 @!LINUX_5_4 +kmod-tg3 +kmod-gpio-button-hotplug +kmod-leds-gpio \
- +kmod-usb-ledtrig-usbport +nu801 +kmod-itco-wdt
+ +kmod-usb-ledtrig-usbport +kmod-itco-wdt
KCONFIG:=CONFIG_MERAKI_MX100
FILES:=$(LINUX_DIR)/drivers/platform/x86/meraki-mx100.ko
AUTOLOAD:=$(call AutoLoad,60,meraki-mx100,1)