aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/modules.mk
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2022-03-19 17:13:42 -0500
committerChristian Lamparter <chunkeey@gmail.com>2022-03-25 18:14:13 +0100
commit3f874519b4200de0d5f78c68dfefe55c42fa0afd (patch)
tree37b6e3d00353f1502443dc456d562ca2ad5a08cc /target/linux/x86/modules.mk
parentcb6f4be13703f0224fc462caaeac14e725c72986 (diff)
downloadupstream-3f874519b4200de0d5f78c68dfefe55c42fa0afd.tar.gz
upstream-3f874519b4200de0d5f78c68dfefe55c42fa0afd.tar.bz2
upstream-3f874519b4200de0d5f78c68dfefe55c42fa0afd.zip
gpio-cdev: re-add nu801 userspace driver
This reverts commit 80b7a8a7f5a0a88fde6dd19f097df4d7cac9ff04. Now that 5.10 is the default kernel for all platforms, we can bring back the NU801 userspace driver for platforms that rely on it. Currently it's used on the MX100 x86_64 target, but other Meraki platforms use this controller. Note that we also now change how we load nu801. The way we did this previously with procd worked, but it meant it didn't load until everything was up and working. To fix this, let's call nu801 from boot and re-trigger the preinit blink sequence. Since nu801 runs as a daemon this is now something we can do. Signed-off-by: Chris Blake <chrisrblake93@gmail.com> (removed empty line, currently only MX100 uses it so: @TARGET_x86) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/x86/modules.mk')
-rw-r--r--target/linux/x86/modules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index 4005ee97ef..0071ebda41 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -88,7 +88,7 @@ define KernelPackage/meraki-mx100
SUBMENU:=$(OTHER_MENU)
TITLE:=Cisco Meraki MX100 Platform Driver
DEPENDS:=@TARGET_x86 @!LINUX_5_4 +kmod-tg3 +kmod-gpio-button-hotplug +kmod-leds-gpio \
- +kmod-usb-ledtrig-usbport +kmod-itco-wdt
+ +kmod-usb-ledtrig-usbport +nu801 +kmod-itco-wdt
KCONFIG:=CONFIG_MERAKI_MX100
FILES:=$(LINUX_DIR)/drivers/platform/x86/meraki-mx100.ko
AUTOLOAD:=$(call AutoLoad,60,meraki-mx100,1)