aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/modules.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-05-01 14:10:35 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-05-07 14:31:22 +0200
commit0cd1fc0fe543eaff04b0263b10b92b056cdef6dd (patch)
tree9788abd0fb641b63fcebefd03c41873c30341042 /target/linux/x86/modules.mk
parentd022451906915c1bf4e36cbee723f323bbb659d1 (diff)
downloadupstream-0cd1fc0fe543eaff04b0263b10b92b056cdef6dd.tar.gz
upstream-0cd1fc0fe543eaff04b0263b10b92b056cdef6dd.tar.bz2
upstream-0cd1fc0fe543eaff04b0263b10b92b056cdef6dd.zip
x86: detangle meraki-mx100 / nu801 build confusion
Grommish reported the dreaded build error that happend with 5.4 since the kernel didn't have the cgpio v2 interface. His reason for the removed 5.4 was that the octeon target had a memory leak issue, so he had to backport the removed 5.4 kernel for his tests. Chen Minqiang chimed in and noted that no matter what (i.e. @TARGET_x86 in depends) didn't prevent the package from being build on other targets. From what I can tell, the reason for this was that +nu801 meant that kmod-meraki-mx100 pulled in an unconditional dependency as part of to the kernel build. |scripts/package-metadata.pl mk tmp/.packageinfo | |$(curdir)/kernel/linux/compile += $(curdir)/firmware/linux-firmware/compile \ | $(curdir)/firmware/prism54-firmware/compile \ | $(curdir)/kernel/gpio-button-hotplug/compile \ | >>> $(curdir)/system/gpio-cdev/nu801/compile <<< change this by making the dependency conditional on the meraki-mx100 module itself. Note that the nu801 enables/sets the KCONFIG for the cgpio v2 interface itself, since the userspace program and not the kernel meraki-mx100 relies on it. Reference: <https://github.com/openwrt/openwrt/commit/eeb8fd4ce7e9> Reported-by: Grommish <grommish@gmail.com> Reported-by: Chen Minqiang <ptpt52@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/x86/modules.mk')
-rw-r--r--target/linux/x86/modules.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index a57a470e8d..2f7f783c16 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -106,7 +106,8 @@ define KernelPackage/meraki-mx100
SUBMENU:=$(OTHER_MENU)
TITLE:=Cisco Meraki MX100 Platform Driver
DEPENDS:=@TARGET_x86 +kmod-tg3 +kmod-gpio-button-hotplug +kmod-leds-gpio \
- +kmod-usb-ledtrig-usbport +nu801 +kmod-itco-wdt +kmod-leds-uleds
+ +kmod-usb-ledtrig-usbport +PACKAGE_kmod-meraki-mx100:nu801 +kmod-itco-wdt \
+ +kmod-leds-uleds
KCONFIG:=CONFIG_MERAKI_MX100
FILES:=$(LINUX_DIR)/drivers/platform/x86/meraki-mx100.ko
AUTOLOAD:=$(call AutoLoad,60,meraki-mx100,1)