aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/legacy/profiles
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-05-17 23:08:13 +0200
committerFelix Fietkau <nbd@nbd.name>2016-06-07 08:58:40 +0200
commit6c2fc113f3480214d6749bc5a57344317957f541 (patch)
treea08e70ba2081e74d48906742c9ea94ae01196d52 /target/linux/x86/legacy/profiles
parent4c33bbf8f40e74e5bbcca084e397d560e5465a95 (diff)
downloadupstream-6c2fc113f3480214d6749bc5a57344317957f541.tar.gz
upstream-6c2fc113f3480214d6749bc5a57344317957f541.tar.bz2
upstream-6c2fc113f3480214d6749bc5a57344317957f541.zip
x86: reorganize x86_32 support
copy current 'generic' target to new 'legacy' target. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/x86/legacy/profiles')
-rw-r--r--target/linux/x86/legacy/profiles/000-Generic.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/x86/legacy/profiles/000-Generic.mk b/target/linux/x86/legacy/profiles/000-Generic.mk
new file mode 100644
index 0000000000..90f989a91d
--- /dev/null
+++ b/target/linux/x86/legacy/profiles/000-Generic.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+ PACKAGES:=kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
+ kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
+ kmod-via-rhine kmod-via-velocity
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))