aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2017-02-06 20:33:36 -0700
committerFelix Fietkau <nbd@nbd.name>2017-04-03 08:51:02 +0200
commit7fe5963be023fd59a11652ecfb065d3405a91c48 (patch)
tree82dd718d3d55b5c154525f2a6a39b839f1190036 /target/linux/x86/image
parentdfacdc6a99757fcf7804b38784fc24f9fad30650 (diff)
downloadupstream-7fe5963be023fd59a11652ecfb065d3405a91c48.tar.gz
upstream-7fe5963be023fd59a11652ecfb065d3405a91c48.tar.bz2
upstream-7fe5963be023fd59a11652ecfb065d3405a91c48.zip
build: allow specifying flow-control to grub on serial console
On the more sophisticated (i.e. deeper FIFO) serial controllers, flow-control might be needed to avoid dropping output. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index f34788d67b..ca5d0123c7 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -32,8 +32,8 @@ endif
GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
ifneq ($(GRUB_SERIAL),)
- GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_GRUB_BAUDRATE)n8
- GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=off
+ GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_GRUB_BAUDRATE)n8$(if $(CONFIG_GRUB_FLOWCONTROL),r,)
+ GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=$(if $(CONFIG_GRUB_FLOWCONTROL),on,off)
GRUB_TERMINALS += serial
endif