aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-30 18:43:39 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-30 18:43:39 +0000
commita64f53f482b3fba4d5ed536a8b53934b97097cf9 (patch)
tree2776e2bdd6bec2cd694800a7e1ed16a93fe935c9 /target/linux/x86/image
parent82221d71e57ec5a055726a33fa8e6bd044df2dae (diff)
downloadupstream-a64f53f482b3fba4d5ed536a8b53934b97097cf9.tar.gz
upstream-a64f53f482b3fba4d5ed536a8b53934b97097cf9.tar.bz2
upstream-a64f53f482b3fba4d5ed536a8b53934b97097cf9.zip
target/x86: add to changes missed from [21246] preventing .vdi & .vmdk image generation
SVN-Revision: 21277
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 1c94634f2c..912dae235f 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -152,7 +152,7 @@ ifneq ($(CONFIG_X86_VDI_IMAGES),)
define Image/Build/vdi
# left here because the image builder doesnt need these
ifeq ($(1),ext2)
- rm $(BIN_DIR)/$(IMG_PREFIX)-ext2.vdi || true
+ rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
VBoxManage convertfromraw -format VDI \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
@@ -166,7 +166,7 @@ ifneq ($(CONFIG_X86_VMDK_IMAGES),)
define Image/Build/vmdk
# left here because the image builder doesnt need these
ifeq ($(1),ext2)
- rm $(BIN_DIR)/$(IMG_PREFIX)-ext2.vmdk || true
+ rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
qemu-img convert -f raw -O vmdk \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk