aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-12-06 09:12:34 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-12-06 09:12:34 +0000
commita155e4fd53dbb4e53b2846eb8fb783833dcf07a0 (patch)
tree1b236a67deabd5ebdcd6439c760a07f3423e3724 /target/linux/x86/image
parent8c2091f823699ac7f7e10ab0dc7512dcc956b043 (diff)
downloadupstream-a155e4fd53dbb4e53b2846eb8fb783833dcf07a0.tar.gz
upstream-a155e4fd53dbb4e53b2846eb8fb783833dcf07a0.tar.bz2
upstream-a155e4fd53dbb4e53b2846eb8fb783833dcf07a0.zip
add rootwait option to the kernel command line (#6209)
SVN-Revision: 18672
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index b412873c38..51490fa791 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -23,19 +23,19 @@ endif
ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
ifneq ($(HOST_OS),Darwin)
define Image/cmdline/squashfs
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootwait
endef
define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
endef
define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2
+ block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
endef
define Image/cmdline/ext2
- root=$(ROOTPART) rootfstype=ext2
+ root=$(ROOTPART) rootfstype=ext2 rootwait
endef
define Image/Build/grub