aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-11-17 19:49:25 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-11-17 19:49:25 +0000
commit93fe520994571365a250d2856b7359fed5d8f019 (patch)
tree251c14f50acb70e568d848e1a53a85a1d5f38c97 /target/linux/x86/image
parent0b27fefa6299eb5ef2e663514226528e4ebbd322 (diff)
downloadupstream-93fe520994571365a250d2856b7359fed5d8f019.tar.gz
upstream-93fe520994571365a250d2856b7359fed5d8f019.tar.bz2
upstream-93fe520994571365a250d2856b7359fed5d8f019.zip
change x86 image generation handling to treat only olpc specially
SVN-Revision: 18441
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Config.in2
-rw-r--r--target/linux/x86/image/Makefile9
2 files changed, 5 insertions, 6 deletions
diff --git a/target/linux/x86/image/Config.in b/target/linux/x86/image/Config.in
index 9dd7ae5877..8768e7cbe6 100644
--- a/target/linux/x86/image/Config.in
+++ b/target/linux/x86/image/Config.in
@@ -1,6 +1,6 @@
config X86_GRUB_IMAGES
bool "Build GRUB images (Linux x86 or x86_64 host only)"
- depends TARGET_x86_generic
+ depends !TARGET_x86_olpc
depends TARGET_ROOTFS_EXT2FS || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS || TARGET_ROOTFS_ISO
select PACKAGE_grub
default y
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 699dcfe6ab..b412873c38 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
export PATH=$(TARGET_PATH):/sbin
-ifeq ($(CONFIG_TARGET_x86_generic),y)
+ifneq ($(CONFIG_TARGET_x86_olpc),y)
BOOTOPTS=$(strip $(subst ",, $(CONFIG_X86_GRUB_BOOTOPTS)))
ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
#"))")) # fix vim's broken syntax highlighting
@@ -120,14 +120,13 @@ endif
define Image/Prepare
$(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
-ifeq ($(CONFIG_TARGET_x86_generic),y)
- $(call Image/Prepare/grub)
-endif
ifeq ($(CONFIG_TARGET_x86_olpc),y)
$(call Image/Prepare/bootscript)
+else
+ $(call Image/Prepare/grub)
endif
endef
-
+
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef