aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2018-11-20 17:20:41 +0100
committerJohn Crispin <john@phrozen.org>2018-11-26 12:05:44 +0100
commit51e199fbe80acb6e95dff942280b0396e094032b (patch)
treec6da10ef52f7bc02ddea6a8f55a4423fd511afac /target/linux/x86/image
parentf78b26163790fdf2b53464ab808af10f72e31c3e (diff)
downloadupstream-51e199fbe80acb6e95dff942280b0396e094032b.tar.gz
upstream-51e199fbe80acb6e95dff942280b0396e094032b.tar.bz2
upstream-51e199fbe80acb6e95dff942280b0396e094032b.zip
x86: add packages files to image bootfs
Add files to bootfs image from selected as built-in packages, which want to install files to targets boot file system. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index b537c40f24..dbf8a8594b 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -85,6 +85,7 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
-e 's#@ROOT@#$(GRUB_ROOT)#g' \
-e 's#@TITLE@#$(GRUB_TITLE)#g' \
./grub.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
+ -$(CP) $(STAGING_DIR_ROOT)/boot/. $(KDIR)/root.grub/boot/
PADDING="$(CONFIG_TARGET_IMAGES_PAD)" SIGNATURE="$(SIGNATURE)" PATH="$(TARGET_PATH)" $(SCRIPT_DIR)/gen_image_generic.sh \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
$(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.grub \
@@ -123,6 +124,7 @@ define Image/Build/iso
-e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
-e 's#@TITLE@#$(GRUB_TITLE)#g' \
./grub-iso.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
+ -$(CP) $(STAGING_DIR_ROOT)/boot/. $(KDIR)/root.grub/boot/
mkisofs -R -b boot/grub/eltorito.img -no-emul-boot -boot-info-table \
-o $(KDIR)/root.iso $(KDIR)/root.grub $(TARGET_DIR)
endef