aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-05-14 10:20:53 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-05-14 10:20:53 +0000
commita9c958c2de59e0747b5dcf82f5fd5b1aaf956c3b (patch)
treeda0c6a06eb4d50def39e6a0fb3bdd3ac813b74fe /target/linux/x86/image
parentb0d4d23bc644dde146070ce692872884dc28a799 (diff)
downloadupstream-a9c958c2de59e0747b5dcf82f5fd5b1aaf956c3b.tar.gz
upstream-a9c958c2de59e0747b5dcf82f5fd5b1aaf956c3b.tar.bz2
upstream-a9c958c2de59e0747b5dcf82f5fd5b1aaf956c3b.zip
make kernels use /etc/preinit by default
SVN-Revision: 15840
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index e64fa19925..6d3c77b77d 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -16,19 +16,19 @@ ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
ifneq ($(HOST_OS),Darwin)
define Image/cmdline/squashfs
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs
endef
define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2
endef
define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
+ block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2
endef
define Image/cmdline/ext2
- root=$(ROOTPART) rootfstype=ext2 init=/etc/preinit
+ root=$(ROOTPART) rootfstype=ext2
endef
define Image/Build/grub