aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-29 00:32:44 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-29 00:32:44 +0000
commit224db523da8a4d49a20300b25081fbb5cccb9626 (patch)
treec626b5df69e04b31617b0e0d5f2c9efc11a7fc17 /target/linux/x86/image
parentd427d303d4f606343ea286dddc58a45358ed0c24 (diff)
downloadupstream-224db523da8a4d49a20300b25081fbb5cccb9626.tar.gz
upstream-224db523da8a4d49a20300b25081fbb5cccb9626.tar.bz2
upstream-224db523da8a4d49a20300b25081fbb5cccb9626.zip
replace old quote stripping with calls to qstrip macro
SVN-Revision: 21242
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 2a6a2e336d..a4399a2b4b 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -10,15 +10,13 @@ include $(INCLUDE_DIR)/image.mk
export PATH=$(TARGET_PATH):/sbin
ifneq ($(CONFIG_TARGET_x86_olpc),y)
-BOOTOPTS=$(strip $(subst ",, $(CONFIG_X86_GRUB_BOOTOPTS)))
-ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
-#"))")) # fix vim's broken syntax highlighting
+BOOTOPTS=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
+ROOTPART=$(call qstrip,$(CONFIG_X86_GRUB_ROOTPART))
endif
ifeq ($(CONFIG_TARGET_x86_olpc),y)
-ROOTPART=$(strip $(subst ",, $(CONFIG_OLPC_BOOTSCRIPT_ROOTPART)))
+ROOTPART=$(call qstrip,$(CONFIG_OLPC_BOOTSCRIPT_ROOTPART))
endif
-#"))")) # fix vim's broken syntax highlighting
GRUB_TERMINALS =
GRUB_SERIAL_CONFIG =
@@ -31,7 +29,7 @@ GRUB_TERMINALS += console
endif
ifneq ($(CONFIG_X86_GRUB_SERIAL),)
-GRUB_CONSOLE_CMDLINE += console=$(strip $(subst ",, $(CONFIG_X86_GRUB_SERIAL))),$(CONFIG_X86_GRUB_BAUDRATE)n8
+GRUB_CONSOLE_CMDLINE += console=$(call qstrip,$(CONFIG_X86_GRUB_SERIAL)),$(CONFIG_X86_GRUB_BAUDRATE)n8
GRUB_SERIAL_CONFIG = serial --unit=0 --speed=$(CONFIG_X86_GRUB_BAUDRATE) --word=8 --parity=no --stop=1
GRUB_TERMINALS += serial
endif