aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-01-07 10:18:55 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-01-07 10:18:55 +0000
commitcc49f7c6e9cc171e2e7cafea7960e1d55bead484 (patch)
tree01c0d099aad3cfff46b65e08a4c8aa3b575ab984 /target/linux/x86/image/Makefile
parent481c01136e0bf2a24c4673a661c156a16a04292e (diff)
downloadupstream-cc49f7c6e9cc171e2e7cafea7960e1d55bead484.tar.gz
upstream-cc49f7c6e9cc171e2e7cafea7960e1d55bead484.tar.bz2
upstream-cc49f7c6e9cc171e2e7cafea7960e1d55bead484.zip
move most of the x86 image generation options to the main file
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39206
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index d3ada9fad2..4b40e64de7 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -23,16 +23,16 @@ ifneq ($(strip $(foreach subtarget,$(USE_ATKBD),$(CONFIG_TARGET_x86_$(subtarget)
GRUB2_MODULES_ISO += at_keyboard
endif
-ifneq ($(CONFIG_X86_GRUB_CONSOLE),)
+ifneq ($(CONFIG_GRUB_CONSOLE),)
GRUB_CONSOLE_CMDLINE += console=tty0
GRUB_TERMINALS += console
endif
-GRUB_SERIAL:=$(call qstrip,$(CONFIG_X86_GRUB_SERIAL))
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
ifneq ($(GRUB_SERIAL),)
- GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_X86_GRUB_BAUDRATE)n8
- GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_X86_GRUB_BAUDRATE) --word=8 --parity=no --stop=1
+ GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_GRUB_BAUDRATE)n8
+ GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1
GRUB_TERMINALS += serial
endif
@@ -42,11 +42,11 @@ endif
ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
-GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_X86_GRUB_TIMEOUT))
+GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_GRUB_TIMEOUT))
-ifneq ($(CONFIG_X86_GRUB_IMAGES),)
+ifneq ($(CONFIG_GRUB_IMAGES),)
- BOOTOPTS:=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
+ BOOTOPTS:=$(call qstrip,$(CONFIG_GRUB_BOOTOPTS))
define Image/cmdline/ext4
root=$(ROOTPART) rootfstype=ext4 rootwait
@@ -158,7 +158,7 @@ define Image/Build/iso
-o $(KDIR)/root.iso $(KDIR)/root.grub $(TARGET_DIR)
endef
-ifneq ($(CONFIG_X86_VDI_IMAGES),)
+ifneq ($(CONFIG_VDI_IMAGES),)
define Image/Build/vdi
# left here because the image builder doesnt need these
ifeq ($(1),ext4)
@@ -172,7 +172,7 @@ ifneq ($(CONFIG_X86_VDI_IMAGES),)
endef
endif
-ifneq ($(CONFIG_X86_VMDK_IMAGES),)
+ifneq ($(CONFIG_VMDK_IMAGES),)
define Image/Build/vmdk
# left here because the image builder doesnt need these
ifeq ($(1),ext4)