aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/geos
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-16 07:05:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-16 07:05:30 +0000
commit9e0759ea2653475f4e891c412fa503e9a9b08478 (patch)
treead7553c4f7d9bd7658a745b9577449d57925801f /target/linux/x86/geos
parentf60113762adbf2cf3aab2c57e2559c61ab98cb18 (diff)
downloadupstream-9e0759ea2653475f4e891c412fa503e9a9b08478.tar.gz
upstream-9e0759ea2653475f4e891c412fa503e9a9b08478.tar.bz2
upstream-9e0759ea2653475f4e891c412fa503e9a9b08478.zip
x86: merge all geode based subtargets into one
Build all geode platform drivers into the kernel Remove kmod-* packages for these drivers Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44809
Diffstat (limited to 'target/linux/x86/geos')
-rw-r--r--target/linux/x86/geos/base-files/etc/config/network53
-rw-r--r--target/linux/x86/geos/base-files/etc/config/system30
-rw-r--r--target/linux/x86/geos/base-files/etc/hotplug.d/button/50-reboot13
-rw-r--r--target/linux/x86/geos/config-default24
-rw-r--r--target/linux/x86/geos/target.mk34
5 files changed, 0 insertions, 154 deletions
diff --git a/target/linux/x86/geos/base-files/etc/config/network b/target/linux/x86/geos/base-files/etc/config/network
deleted file mode 100644
index d12d528032..0000000000
--- a/target/linux/x86/geos/base-files/etc/config/network
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright (C) 2011 OpenWrt.org
-
-config interface loopback
- option ifname lo
- option proto static
- option ipaddr 127.0.0.1
- option netmask 255.0.0.0
-
-config interface lan
- option ifname "eth0 eth1"
- option type bridge
- option proto static
- option ipaddr 192.168.1.1
- option netmask 255.255.255.0
- option ip6assign 60
-
-config atm-bridge
- option unit 0
- option atmdev 0
- option vpi 0
- option vci 35
- option encaps llc
- option payload bridged
- option sendsize 2040
-
-config interface wan
- option proto dhcp
- option ifname nas0
- # clone your eth0 address here
- # option macaddr '00:0A:FA:22:00:80'
-
-config interface wan6
- option ifname nas0
- option proto dhcpv6
-
-config globals globals
- option ula_prefix auto
-
-
-# 2nd interface on Geos2
-#config interface wan
-# option proto pppoa
-# option atmdev 1
-# option vpi 8
-# option vci 32
-# option encaps vc
-# option username 'username@myisp.net'
-# option password 'password'
-# option keepalive 3
-# option defaultroute 1
-# option peerdns 1
-# option pppd_options 'kdebug 1 debug noccp'
-
diff --git a/target/linux/x86/geos/base-files/etc/config/system b/target/linux/x86/geos/base-files/etc/config/system
deleted file mode 100644
index 988c849ec1..0000000000
--- a/target/linux/x86/geos/base-files/etc/config/system
+++ /dev/null
@@ -1,30 +0,0 @@
-
-config system
- option hostname OpenWrt
- option timezone UTC
-
-config timeserver ntp
- list server 0.openwrt.pool.ntp.org
- list server 1.openwrt.pool.ntp.org
- list server 2.openwrt.pool.ntp.org
- list server 3.openwrt.pool.ntp.org
-
-config led
- option default 0
- option name LAN
- option sysfs 'geos:1'
- option trigger netdev
- option mode 'tx rx'
- option dev 'br-lan'
-
-config led
- option default 0
- option name WiFi
- option sysfs 'geos:2'
- option trigger 'phy0tpt'
-
-config led
- option default 0
- option name Health
- option sysfs 'geos:3'
- option trigger 'heartbeat'
diff --git a/target/linux/x86/geos/base-files/etc/hotplug.d/button/50-reboot b/target/linux/x86/geos/base-files/etc/hotplug.d/button/50-reboot
deleted file mode 100644
index bf893c15bb..0000000000
--- a/target/linux/x86/geos/base-files/etc/hotplug.d/button/50-reboot
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-
-logger -t button -p daemon.info "$BUTTON/$ACTION"
-
-case "$BUTTON/$ACTION" in
-
-reset/released)
- reboot -f
- ;;
-
-esac
-
-exit 0
diff --git a/target/linux/x86/geos/config-default b/target/linux/x86/geos/config-default
deleted file mode 100644
index 66ae2c7afc..0000000000
--- a/target/linux/x86/geos/config-default
+++ /dev/null
@@ -1,24 +0,0 @@
-# CONFIG_ATA_PIIX is not set
-CONFIG_DMI=y
-CONFIG_DMIID=y
-# CONFIG_DMI_SYSFS is not set
-CONFIG_GEOS=y
-CONFIG_GPIOLIB=y
-CONFIG_GPIO_SYSFS=y
-# CONFIG_HIGHMEM64G is not set
-CONFIG_HWMON=y
-# CONFIG_ISDN is not set
-# CONFIG_LEDS_CLEVO_MAIL is not set
-# CONFIG_M486 is not set
-# CONFIG_MATH_EMULATION is not set
-CONFIG_MGEODE_LX=y
-CONFIG_NLS=y
-CONFIG_PATA_CS5536=y
-CONFIG_PCI_LABEL=y
-# CONFIG_SCx200 is not set
-CONFIG_THERMAL_HWMON=y
-CONFIG_X86_CMOV=y
-CONFIG_X86_DEBUGCTLMSR=y
-CONFIG_X86_TSC=y
-CONFIG_X86_USE_3DNOW=y
-CONFIG_X86_USE_PPRO_CHECKSUM=y
diff --git a/target/linux/x86/geos/target.mk b/target/linux/x86/geos/target.mk
deleted file mode 100644
index 5c265749f5..0000000000
--- a/target/linux/x86/geos/target.mk
+++ /dev/null
@@ -1,34 +0,0 @@
-BOARDNAME:=Traverse Geos
-FEATURES:=squashfs ext4 pci usb gpio broken
-DEFAULT_PACKAGES += \
- kmod-crypto-hw-geode kmod-crypto-ocf \
- kmod-gpio-cs5535-new kmod-gpio-nsc \
- kmod-wdt-geode kmod-cs5535-clockevt kmod-cs5535-mfgpt \
- kmod-cs5536 \
- kmod-hwmon-core kmod-hwmon-lm90 \
- kmod-8139cp kmod-solos-pci kmod-sched \
- kmod-i2c-core kmod-i2c-gpio \
- kmod-i2c-algo-bit kmod-i2c-algo-pca kmod-i2c-algo-pcf \
- kmod-i2c-scx200-acb \
- kmod-usb-core kmod-usb2-pci kmod-usb-ohci \
- kmod-cfg80211 kmod-mac80211 \
- kmod-mppe kmod-pppoa kmod-pppol2tp \
- kmod-ath5k kmod-ath9k \
- kmod-leds-gpio kmod-input-gpio-keys-polled \
- kmod-button-hotplug \
- kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
- kmod-ledtrig-netdev \
- kmod-cpu-msr \
- soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
- hwclock wpad flashrom tc
-CS5535_MASK:=0x0E000048
-
-CPU_TYPE := geode
-
-define Target/Description
- Build firmware images for Traverse Geos board
-endef
-
-define KernelPackage/gpio-cs5535-new/install
- sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535-new
-endef