aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/geos
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-10-10 22:48:33 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-10-10 22:48:33 +0000
commite9b7a65dec5a524a05e77eef333a95dcc3ebd57e (patch)
tree6d000bb59c47a2d9aa270e14d52c4c6677b0b10f /target/linux/x86/geos
parent720cb42823968bbf40b52976de6c4a577ef77ac3 (diff)
downloadupstream-e9b7a65dec5a524a05e77eef333a95dcc3ebd57e.tar.gz
upstream-e9b7a65dec5a524a05e77eef333a95dcc3ebd57e.tar.bz2
upstream-e9b7a65dec5a524a05e77eef333a95dcc3ebd57e.zip
[Patch v2] Geos -- new x86 subtarget definition
This defines the Geos platform from Traverse Technologies in AUS. This is a Geode LX800 with 512MB of DDR400 memory, 2 8139CP interfaces, 2 Solos ADSL2+ interfaces, USB, serial console, CF slot, and miniPCI slot. I'll add support for the LEDs separately. Signed-off-by: Philip A. Prindeville git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23390 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/geos')
-rw-r--r--target/linux/x86/geos/config-default25
-rw-r--r--target/linux/x86/geos/target.mk25
2 files changed, 50 insertions, 0 deletions
diff --git a/target/linux/x86/geos/config-default b/target/linux/x86/geos/config-default
new file mode 100644
index 0000000000..20f10a29c6
--- /dev/null
+++ b/target/linux/x86/geos/config-default
@@ -0,0 +1,25 @@
+# CONFIG_ACPI is not set
+# CONFIG_DMI is not set
+CONFIG_CPU_SUP_AMD=y
+CONFIG_GEODE_MFGPT_TIMER=y
+# CONFIG_GEODE_WDT is not set
+CONFIG_HAVE_PERF_EVENTS=y
+CONFIG_HWMON=y
+# CONFIG_HWMON_DEBUG_CHIP is not set
+# CONFIG_ISA is not set
+# CONFIG_INPUT is not set
+# CONFIG_KEYBOARD_ATKBD is not set
+# CONFIG_M486 is not set
+CONFIG_MGEODE_LX=y
+# CONFIG_MOUSE_PS2 is not set
+# CONFIG_PCSPKR_PLATFORM is not set
+CONFIG_PROCESSOR_SELECT=y
+# CONFIG_SCx200 is not set
+# CONFIG_SERIO_I8042 is not set
+# CONFIG_SERIO_LIBPS2 is not set
+CONFIG_X86_DEBUGCTLMSR=y
+# CONFIG_X86_DS is not set
+CONFIG_X86_L1_CACHE_SHIFT=5
+CONFIG_X86_TSC=y
+CONFIG_X86_USE_3DNOW=y
+CONFIG_X86_USE_PPRO_CHECKSUM=y
diff --git a/target/linux/x86/geos/target.mk b/target/linux/x86/geos/target.mk
new file mode 100644
index 0000000000..0387a31128
--- /dev/null
+++ b/target/linux/x86/geos/target.mk
@@ -0,0 +1,25 @@
+BOARDNAME:=Traverse Geos
+FEATURES:=squashfs pci usb gpio
+DEFAULT_PACKAGES += kmod-ata-via-sata kmod-crypto-hw-geode \
+ kmod-gpio-cs5535 kmod-gpio-nsc \
+ kmod-wdt-geode kmod-hwmon-core kmod-hwmon-lm90 \
+ kmod-8139cp kmod-solos-pci \
+ kmod-i2c-core kmod-i2c-gpio \
+ kmod-i2c-algo-bit kmod-i2c-algo-pca kmod-i2c-algo-pcf \
+ kmod-usb-core kmod-usb2 kmod-usb-uhci \
+ kmod-cfg80211 kmod-mac80211 \
+ kmod-mppe kmod-pppoe kmod-pppoa kmod-pppol2tp \
+ kmod-ath kmod-ath5k kmod-ath9k
+
+CS5535_MASK:=0x0E000048
+
+CFLAGS += -Os -march=k6-2 -fno-align-functions -fno-align-loops -fno-align-jumps \
+ -fno-align-labels
+
+define Target/Description
+ Build firmware images for Traverse Geos board
+endef
+
+define KernelPackage/gpio-cs5535/install
+ sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535
+endef