aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/alix2/target.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-02-01 15:31:23 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-02-01 15:31:23 +0000
commitb6b0a6cbbb276280c33413fb353c08115fa8fd86 (patch)
treeadd80ce9fd905bef37a4d603b409938598efff11 /target/linux/x86/alix2/target.mk
parentdf061331d2e8ae492130e5612d438eb575153f27 (diff)
downloadupstream-b6b0a6cbbb276280c33413fb353c08115fa8fd86.tar.gz
upstream-b6b0a6cbbb276280c33413fb353c08115fa8fd86.tar.bz2
upstream-b6b0a6cbbb276280c33413fb353c08115fa8fd86.zip
[PATCH] alix2: correct h/w configuration
Bump to version 3.2. Simplify and correct kernel config (based on x86/config-3.2). Drop obsolete CS5535 GPIO driver. [Patch from Philipp Prindeville, via http://patchwork.openwrt.org/patch/1804/] git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29981 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/alix2/target.mk')
-rw-r--r--target/linux/x86/alix2/target.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/x86/alix2/target.mk b/target/linux/x86/alix2/target.mk
index cece30e173..d9f08f6dba 100644
--- a/target/linux/x86/alix2/target.mk
+++ b/target/linux/x86/alix2/target.mk
@@ -1,9 +1,9 @@
+LINUX_VERSION:=3.2.1
BOARDNAME:=PCEngines alix2
FEATURES:=squashfs jffs2 ext4 pci usb gpio
-ALIX2_GPIO = $(if $(findstring 2.6.32,$(LINUX_VERSION)),gpio-cs5535,gpio-cs5535-new)
DEFAULT_PACKAGES += \
kmod-crypto-hw-geode kmod-crypto-ocf \
- kmod-$(ALIX2_GPIO) kmod-gpio-nsc \
+ kmod-gpio-cs5535-new kmod-gpio-nsc \
kmod-wdt-geode kmod-cs5535-clockevt kmod-cs5535-mfgpt \
kmod-cs5536 \
kmod-hwmon-core kmod-hwmon-lm90 \
@@ -32,6 +32,6 @@ define Target/Description
Build firmware images for PCEngines alix2 board
endef
-define KernelPackage/$(ALIX2_GPIO)/install
- sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-$(ALIX2_GPIO)
+define KernelPackage/gpio-cs5535-new/install
+ sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535-new
endef