aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-02-09 12:33:17 +0000
committerJo-Philipp Wich <jow@openwrt.org>2016-02-09 12:33:17 +0000
commit4aeeead303cda2a85895fde9d3983eae323a30e1 (patch)
tree30856f12366d0b265eb6a8b04825ad8449c52672 /target/linux/x86/Makefile
parent6b73b7a8ec744f557200f1b7be0c3018244996d6 (diff)
downloadupstream-4aeeead303cda2a85895fde9d3983eae323a30e1.tar.gz
upstream-4aeeead303cda2a85895fde9d3983eae323a30e1.tar.bz2
upstream-4aeeead303cda2a85895fde9d3983eae323a30e1.zip
x86: preserve partition table on sysupgrade
With this patch sysupgrade will write directly to the partitions instead of to the main disk. The UUID is copied from the image to the MBR as well. This prevents the mbr from being completely overwritten and losing the partition table. The -p option has been added to maintain the original behavior and overwite the entire disk with the new image. Tests have been added to ensure that the image partitions match up with the active partitions. Signed-off-by: Rob Mosher <nyt-openwrt@countercultured.net> SVN-Revision: 48682
Diffstat (limited to 'target/linux/x86/Makefile')
-rw-r--r--target/linux/x86/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index e4bc0d9a50..45bb8c7cac 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -13,6 +13,8 @@ FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
SUBTARGETS=generic xen_domu ep80579 geode kvm_guest 64
MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+DEFAULT_PACKAGES += partx-utils
+
KERNEL_PATCHVER:=4.4
KERNELNAME:=bzImage