aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/Makefile
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2021-08-11 11:58:45 +0200
committerPaul Spooren <mail@aparcar.org>2022-09-19 19:30:15 +0200
commit027845b4ce906a7819e12f6298b96dba0cb4a183 (patch)
tree06dccc56a729f82681dccc9d8e2b309fd72de1ce /target/linux/x86/Makefile
parente2ffb61821b85d1b37bfce8b874896f157441483 (diff)
downloadupstream-027845b4ce906a7819e12f6298b96dba0cb4a183.tar.gz
upstream-027845b4ce906a7819e12f6298b96dba0cb4a183.tar.bz2
upstream-027845b4ce906a7819e12f6298b96dba0cb4a183.zip
target/x86: add grub2-bios-setup to DEFAULT_PACKAGES
With the commit 5876d6a62fc0ae5799e7d9c896356f75c99a6f0a the command under `/usr/sbin/grub-bios-setup` has been moved to its own package named `grub-bios-setup`. The script `81_upgrade_bootloader` under `/lib/preinit` is used by all x86 targets to update the bootloader. The script is using the command `grub-bios-setup` for this. I get the following output at the first boot after the upgrade. `/etc/preinit: line 9: /usr/sbin/grub-bios-setup: not found`. To fix this, the DEFAULT_PACKAGES dependency is extended by the entry `grub2-bios-setup` so that the missing command is installed again. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'target/linux/x86/Makefile')
-rw-r--r--target/linux/x86/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 880ac73df8..20539e5ed3 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -17,7 +17,10 @@ KERNELNAME:=bzImage
include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs kmod-button-hotplug
+DEFAULT_PACKAGES += \
+ partx-utils mkf2fs \
+ e2fsprogs kmod-button-hotplug \
+ grub2-bios-setup
$(eval $(call BuildTarget))