aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-04-11 12:36:55 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-04-11 12:36:55 +0000
commit15e8d2e0b7e28d0a1ae8ffc848ca5b35e82362de (patch)
tree2ce61df795f2025bddb44de7715816298bdab534 /target/linux/x86/Makefile
parent62b96185c30d8a9fcd38173fc991b3e9145bca92 (diff)
downloadupstream-15e8d2e0b7e28d0a1ae8ffc848ca5b35e82362de.tar.gz
upstream-15e8d2e0b7e28d0a1ae8ffc848ca5b35e82362de.tar.bz2
upstream-15e8d2e0b7e28d0a1ae8ffc848ca5b35e82362de.zip
add net5501 support
This patch brings up the net5501 platform. Note that the x86/ target included support for all x86/ class processors. That's not technically correct. This should be constrained only to the "generic" subtarget. Every x86-class target that isn't generic should be able to select only the optimizations/capabilities applicable to that architectural variant. It's also assumed that all x86 processors have keyboard & mouse ports, ISA, DMI, ACPI... the embedded ones typically don't. Again, moving that to the generic subtarget. Fortunately, this was a fairly benign tweak. The net5501 board includes the following logic: Geode/LX processor CS5535 super-I/O chip PC87360 sensor chip Via Rhine Ethernet controllers Via Sata controllers USB, LEDS, I2C Signed-off-by: Philip Prindeville <philipp_subx@redfish-solutions.com> SVN-Revision: 20794
Diffstat (limited to 'target/linux/x86/Makefile')
-rw-r--r--target/linux/x86/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 4cf011af78..6b248f68c3 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -10,7 +10,7 @@ ARCH:=i386
BOARD:=x86
BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
-SUBTARGETS=generic olpc xen_domu ep80579
+SUBTARGETS=generic olpc xen_domu ep80579 net5501
LINUX_VERSION:=2.6.32.10